RunTime dashboard BAQ not working for no reason

So I have a BAQ/dashboard in a runtime dashboard, that all of the sudden doesn’t work. The BAQ works fine in the designer with a criteria set on the table, but in a dashboard, it just returns nothing. We’ve been using it for at least a year with no issues until now. Any idea what could be causing the problem?

In pilot it works just fine. This a job we did last year.

In production, nothing.

These are the filters that I have on the grid.


The options for the tracker.

here’s the query phrase

	('') as [Calculated_Blank1],
	[JobMtl].[PartNum] as [JobMtl_PartNum],
	('') as [Calculated_Blank2],
	[JobMtl].[Description] as [JobMtl_Description],
	('') as [Calculated_Blank3],
	('') as [Calculated_Blank4],
	(ceiling(TotatlQTY*.10)) as [Calculated_TenPercent],
	[JobMtl].[JobNum] as [JobMtl_JobNum],
	[Part].[ClassID] as [Part_ClassID],
	(sum( JobMtl.RequiredQty )) as [Calculated_TotatlQTY],
	[JobMtl].[Company] as [JobMtl_Company]
from Erp.JobMtl as JobMtl
inner join Erp.Part as Part on 
	JobMtl.Company = Part.Company
	and JobMtl.PartNum = Part.PartNum
	and ( Part.ClassID = 'HDWR'  or Part.PartNum in ('335-3-0273', '622-0-0245', '622-0-0380', '622-0-0471', '622-0-0478', '622-0-0479', '622-0-0697', '622-0-0737', '622-0-0919')  )

inner join Erp.JobAsmbl as JobAsmbl on 
	JobMtl.Company = JobAsmbl.Company
	and JobMtl.JobNum = JobAsmbl.JobNum
	and JobMtl.AssemblySeq = JobAsmbl.AssemblySeq
	and ( JobAsmbl.PartNum <> 'Hardware Overage'  )

where JobMtl.JobNum = '403413-2-1'

group by [JobMtl].[PartNum],
order by JobMtl.PartNum

it’s really weird. I got it to work for the old job by adding the company in the display fields, but when I tried the new job that is giving us problems, it breaks it for that job and every other one that I try.

Here’s the new job in the designer.

I don’t know what’s going on here…

Never mind, nothing is over 15 :man_facepalming: The job seemed like it was big enough that it should have worked.

I don’t know what I did to think that it was broken for other jobs. Trying to go too fast I guess.


topics like this scream stat padder. :stuck_out_tongue:

1 Like

No, it’s just me freaking out, and the site not having a “delete thread” option…

And something weird was going on. I still don’t why the old job wasn’t working there for a while. I have the screen shot to prove it. But it works now. :man_shrugging: