Scheduling Issues in E10, Infinite capacity still choosing multiple resources

Continuing the discussion from How are Resources Choosen for the Schedule:

Has anyone ever had a broken resource group / scheduler?

Just as Tim states in his post, aren’t jobs supposed to be picking from the first resource only if there is infinite capacity? I have tried running Job Scheduling… with ignoring constraints on and backwards, it keeps supplying 7 resources onto the job instead of using the first resource.

What’s stranger is that there are 8 resources for it to pick from, and one of the 7 that show up in the scheduled resources doesn’t appear in the resource schedule board or in a query we made based on ResourceTimeUsed.

We have various jobs selecting the resource group associated with our employees, instead of the “_RESOURCE” group that we have at the top because of the underscore. It’s been working for years and then all of a sudden between last week and this week it broke and started assigning jobs to employee resources.

Has anyone ran into this? I can’t move them off the resource group because they are being assigned on a job, and I can’t get the scheduler to stop using them.

Thank you.

How many scheduling blocks do you have?

1 Like

I did attempt setting that to 0. Coincidentally, this specific resource group was also set to 7, but even after setting it to 0 and running the job scheduling with ignore constraints etc, it still scheduled out 7 resources.

We also have an outdated testing environment from a snapshot in July, and the scheduling blocks were still set to 7 back then, but the issue just started presenting itself today.

You also need to check the Scheduling Blocks in the method and the job. They could be set there also.

Man I should come in here instead of banging my head on the wall more often… That was the oversight! Thank you very much!

If you had to give your best guess, why did this only now start becoming an issue?

Were there any changes to your process at all? Like maybe your methods were created using resources as the scheduling requirement and you switched to using the resource group?

That’s a good question, seems only this one specific resource was affected by the schedule block size. I will ask our engineering documentation team if they changed any of their methods lately. I believe the answer is no, but it could have been an oversight recently.

The others worked as soon as I rescheduled (we had a few other employees in other resource groups that were assigned randomly once each, but rescheduling worked on them).

Thanks for all your help!