Service Connect issues with first workflow

I am working on building my first workflow and I have been running into some issues.

I am building this to create Sales orders from an XML. When it gets to the first method call it fails with this error: msg:descriptionUnspecified error: Failed to execute proxy assembly: Record not found.</msg:description>
When I go to the processing info and hit validate I see this error:
Trace document namespace ‘’ does not correspond to validation schema namespace: ‘’.

This is the mapping for the node going into the method:

This is the mapping for the node coming out of the method:

Any assistance would be greatly appreciated. I have tried searching for this error and haven’t been able to find anything relevant.

Can you possibly look up the customer by using GetList and construct the relevant WhereClause

For some reason this is throwing a server error
Conversion failed when converting the nvarchar value ‘BMCMFG’ to data type int

I have no idea why it is doing this or where this data is coming from as I searched the tables and am unable to find that specific value anywhere

Somehow it started working on it’s own after changing it to GetList, and then back to GetByCustId. Used the same mappings and everything worked