Slow Client - Follows User

Some of my users (myself included) have been experiencing the E10 client being extremely slow. Up until today, I thought it was computer related and have been trying to troubleshoot computers to resolve this issue. However, we did some testing here today and it seems to not be related to the computer…but to the user.
For example, Amber is basically unable to use the E10 Client on her computer because of how slow it is. So Adam logs into E10 (Amber is still logged into Windows) and all is good. He can go through and do anything he wants with ease. If I log into E10 on Ambers computer, it is slow as can be (just like it is on my workstation).
If Amber logs into E10 on Adam’s computer, it is slow, but Adam can log in and it is fine.
I have no idea which direction to look to even being trying to solve this.

I do know that none of the affected users have any traces going on, so that isn’t hindering it. There are not any tasks running in E10 for the affected users either.
These users do not use MES, so it isn’t anything like an activity from 3 months ago is still clocked in.

Anyone have any thoughts or experience with this?

EDIT: I should mention that we are on 10.1.600.15

Hi Jason,

I would try clearing the client cache first:


If that fails you can try to clear personalisations but you will have some work in setting screen layouts again.

I tried clearing the cache, as well as the C:\ProgramData\Epicor\server-808 folder, neither of which helped.
But, you mentioned clearing the personalization’s…is there a way to clear all personalizations for a user?

Yes, it’s called personalization purge. I can’t believe I hadn’t mentioned this yet.

You can search by user and then select certain personalizations and purge them or select all and purge them.

I had an issue like this a couple weeks ago and this fixed it.

I just tried that on my account since I also have these issues, and it is not any better.

Did you close epicor and re-open?

Can you do a trace as Amber and Adam (both doing the same operations) and let us see the execution times? (on the same machine)

Also delete her personalization’s for this screen as @utaylor mentioned.

1 Like

Solution Found!

After uninstalling Epicor, removing all traces of it from C:\ProgramData, C:\Epicor, C:\Program Files\Common Data, AppData\Local and AppData\Roaming, etc., etc., then reinstalling Epicor and trying again, it was still slow as can be. And when I say slow, I mean SLOW. Opening Customer Tracker was taking over 30 seconds. After tying in a customer ID and hitting tab, it took over 20 seconds to display the customer data. So yes, that is extremely slow.

After that epic failure, I went back into the settings to see what else I could possibly try. I opened up preferences and then Theming…I checked the box to disable themes, and restarted Epicor. Now it loads exceptionally fast. It now takes about 2.5 seconds to display the Customer Tracker menu, and less than 1.5 seconds to show the customer data.

For grins and giggles, I went and re-enabled themes, restarted Epicor, and it was back to being as slow as molasses. This tells me that it is most definitely an issue with the theme engine.

I disabled themes for Amber as well as Colin (who also was having issues) and both of them are signing my praises now.

So this is where I am at a loss. This never was an issue in the past. But for some users the themes have started to pose a problem. I have no idea what could possibly have triggered this to start happening to random users. Most of us have never even changed from the default theme that Epicor sets.

Has anyone else ever noticed this?

This sounds like its related to the KB Microsoft bug. It was heavily influenced by graphics / theme.

This little fella


Seriously? KB5000802 and KB5000808?!? Those are the same 2 KB’s that busted my Kyocera printer drivers a while back. I had no idea that they were tied to this issue as well.

sigh well, at least I have a resolution in place now.

Thank you for your ideas everyone :blush:

1 Like

There’s a fix in that thread too a Microosoft Patch.

1 Like

@josecgomez - It does have a patch, but it does not work for Windows 10 Build 21H1. :frowning:
No worries though, as I am just having my users disable theming, and they seem to be fine with it for the most part. Only had 1 user give any pushback…and that was expected.