Smart Client Issue 'System.Void' is not defined or imported

I suspect this issue is a smart client issue, I have opened a case with Epicor and followed their instructions, but Epicor is stumped. I have uninstalled and reinstalled the Smart Client more than once, but this issue still persists. I see the issue when I “Check Syntax” on a C# expression box on a BPM and I get other errors when I Validate a BPM. When I use another PC, I do not get these errors or issues, so that is why I suspect it is the Smart Client installation.

I am hoping someone else has seen this issue and remembers the fix.

Here is what a very simple C# expression does:

I see ttOrderHed but not ttOrderHedRow on your Available variables list.

Randy, When you double click on the ttOrderhed.OTSName form the Available Variables list, it pulls into the Editor box as ttOrderHedRow.OTSName. If I manually delete the Row, and click the check syntax button, I still get the ‘System.Void’ issue:

When I test from another PC (with my same login and this same exact BPM and the same exact variable c# expression), the syntax is fine:

Check the .Net runtime versions on both computers.

1 Like

On the machine that gives the errors, I am on .NET Framework 4.8.4084.0
On the machine that does NOT give me errors, I am on the same version 4.8.4084.0.

Is .NET 6 runtime installed on the machine? I think it is required for successful development of BPMs.

EDIT: Just realized this is in the Epicor10 section, but your ‘version’ is ‘Current SaaS Version’. My response was assuming this was Kinetic SaaS (11.2.x)

2 Likes

Are you sure .Net 6 isn’t installed on the “working” system?

1 Like

We’ve been down this road before.

The last solution that worked was to uninstall, DELETE the client folder, and reinstall.