[SOLVED]-Update-able BAQ for Labor Approval/Activity


“A Labor Detail Record is either active or has not been approved”- Epicor 10.0.700.2

i know this is an old issue and i have tried looking for the BAQ that helps me get around this 10.0.700.2 bug. I created an updateable BAQ using LaborDtl (maybe that’s my problem) while following countless videos on how to make a BAQ updateable. On my BAQ i have the active trans checkbox which can be changed in my dashboard but, like every other updateable field, i cant save the change. I am trying to change the TimeStatus on jobs that i am unable to close due to the error mentioned in the beginning of this post. i have taken some screenshots hoping someone can point out my mistakes.

My BAQ main screen:

My selected Table:

The fields in my BAQ:

The Updateable BAQ screen:

Update Processing:

After creating the dashboard (before deployment):

Do i need to do anything in the screen below?:

And then Whenever i try and save my changes i am faced with he following error:

If you call service, they will send you one already made to fix those records. The one they sent me uses the LaborDtlSearch instead of LaborDtl. I attached the BAQ they sent me, but we are on 10.0.700.4, I’m not sure if that will go backwards to .2 or not.

UBAQlaborUPDE10.baq (58.7 KB)


it actually imported without an issue. I was able to change the time status of the jobs we needed to close. Thank you for your help

does anyone have the same baq but for version 9.05.607B? we just had an employee clock out for the day and not close out his job. Any help will be greatly appreciated? thanks.

You can do it from the Epicor Admin Tools. I only made my UBAQ because it happened a lot and I wanted someone else to handle it.
8920 End Activity on Labor Detail Trans. 8930 would do the same for a LaborHed

The E9 UBAQ is straightforward the screenshots above would work in 9 also. I would send you mine, but it is 905.702A.

if you can send me it I could try to import it. Thanks.

here is the baq and the screen shots to make it.

update labordtl.dbd.baq (14.1 KB)

how did you get that where to show up on the first image?

nevermind lol filled out wrong area. long day so far lol

Thanks very much for helping. It worked. It allowed me to make it not active to delete the transaction.

Your Welcome


Am new to Epicor 10…I have downloaded the suggested updateable BAQ suggested in above string.
However, all transactions are “A” and no “ActiveTrans” boxes are checked…so I am not sure for what to check on next to be able to successfully close several jobs. thanks

Do you have the exact same error message when you are trying to close the job?

Or does it say something else?


Without clicking around in your system I’m not sure. My hunch is that there is one that you just aren’t seeing. Did you add filters to the BAQ so that only ones that aren’t “A” are showing?

How many rows returned when you ran the BAQ?

Ok, I just noticed the file/field for Status did not actually update from E to A.

Received the Query Execution Message

I had one row of 162 with Status = E

Severity: Exception, Table: LaborDtl, Field: , RowID: 4847c7f6-f193-478c-b959-2e85c53405df, Text: This function is not allowed.

Query returned 1 row(s).

Can you post a screen shot please.

if we are a ‘hosted-SAS’ site are updateable BAQ’s going to work?

I think so. That would be a question for @Mark_Wonsil. But the UBAQ doesn’t run any custom code, so I don’t see it being a problem.

Are you Multi-Tenant or Public Cloud/Dedicated Tenant @danag?