Some BAQs missing from current Company

When trying to test my dashboard I get the following error, “Some BAQs (FreightTrack) missing from current Company. Please contact system administrator.” My BAQ is using a UD table, however I’ve been able to deploy other UD table related BAQs in the past. The dashboard is a simple table output of the BAQ. The BAQ runs without any issues in the BAQ designer. I can provide screenshots if anyone has any suggestions.

Edit: Another screenshot:

Make sure that on the BAQ the following 2 Checkboxes are checked:

  • All Companies
  • Shared
2 Likes

those I have checked, cross-company is not checked, though I don’t think that matters in this case.

Interesting… I only had this happen when I created a BAQ as a user I later deactivated… Then I had to do a “Change Author” on those BAQs - even after I re-activated the User. Other than that, I wouldnt know.

3 Likes

I’m guessing it has something to do with the particular UD table I made, however it was working in an updatable dashboard that I built to update the table. I’ve tried remaking the BAQ from scratch now, as well as export and import, and copy it. So the only thing left must be the table itself, I’m assuming.

It looks like this has to do with us trying to match the InvcDtl.PackNum with the APInvcHead.InvoiceComment fields. For some reason the BAQ will run without an issue in the BAQ designer, and even in the BAQ report designer, but not as a dashboard. We’re doing this to track our actual freight payments with the invoices. I’m guessing we’ll have to find an alternative method for this.

Ok, I’ve now narrowed it down to adding the condition: APInvHead.InvoiceComment Is Not Like ‘%[^0-9]%’
image

if you say ALL companies then the multi-company process needs to copy the BAQ to each company, no?
are the multicompany processes running? (check log)

1 Like

Two things:
-If you create a new global BAQ, is it accessible from other companies?
-Can you check the QueryHdr table? You want to see that there is only one query with that QueryID that is global, shared, and CompanyVisibility set to 10. I’ve seen some funkiness in various versions where something will be mis-toggled here in the table and I need to delete / recreate using the BAQ designer.

1 Like

The multicompany processes are running and no there are no other QueryIDs with this name, I’ve built most of our queries. The solution ended up being to just make another subquery to use ISNUMERIC within a calculated field instead of using a regular expression in the criteria. I can’t explain why using a regular expression in the criteria caused this error. I’m pretty sure I’ve used that method on other BAQs. Maybe it’s a bug, maybe its Maybelline.

I faced the exact error - “BAQ missing for current company” and it was resolved by removing the security ID from the BAQ.

Thanks
Subha

1 Like