SSRS Error - Column '{calculated column name}' does not belong to table {Epicor table name}.”

In an upgrade from 10.1.400.14 to the custom SSRS report “AR Form” now fails to run with the below error…

“Program Ice.Services.Lib.RunTask raised an unexpected exception with the following message: RunTask: Column ‘Calc_DspDocLineTax’ does not belong to table InvcDtl.”

Where is this field being referenced?

  • I took all the RDL files (main report and all the sub-reports/sub-sub-reports) and searched all the XML and could not find this field referenced in any of the SSRS RDL files.
  • I also exported the Report Data Definition and then opened it up in a text editor and searched for the field too, and could not find it in the RDD either.
  • Where else could this field be referenced?

This is a highly customized SSRS report with sub-reports and sub-reports inside the sub-reports (about 9 in total), so re-building this report is not ideal. I’d really like to track-down this rogue field reference and correct it.

(NOTE: This started out being one of the “…exceeds the maximum of 1024 columns” errors. Had worked on
excluding columns, and then when I stopped to see if I had gotten below the limit, I received this error. But this calculated field is not showing in the Report Data Definition.)

Any suggestions or ideas on where to find this ghost field?

Are there custom BAQs in the report? If yes, you should go and check those.

Where would one double-check to confirm that?

Can one confirm that by looking in the Report Data Definition and then expanding the Data Sources, select each one and look at the “Report BAQ” tab? If yes, I did that for all 21 data sources and the “Report BAQ” tab is blank on each of the data sources.

If that’s not the way to check to see if there are BAQ’s involved in the report, how do you check?

Are you trying to run this in Epicor and getting the error in the print screen? Are there any check boxes or filters that could be using this field on the report screen?

I ran into this issue back when I moved from 10.1.500.21 to 10.1.600.13. The exact fields you reference gave me issues due to the new tax by line features in 10.1.600. I was advised by our consultant to rebuild the form from scratch to be safe and that’s the route I ended up going. Took about 40 hours and used it as an opportunity to redesign our invoice.

Does your AR Form use a custom Report Data Definition in addition to the subreports within SSRS? In theory you should just be able to use the new RDD with your old SSRS form and merge the new query within the dataset if you don’t need the new functionality (no need to manually place all the fields on the form).

Here is a screenshot on where to see it for those that may not be familiar with SQL Server Report Builder:

The Calc_DspDocLineTax is on the T2 table.

1 Like

I have the same problem. We are currently testing reports migrated from 10.1.400 to 10.2.500. ARform was customized with a custom data definition. I looked in the dataset SQL code its not in the T2 table. I searched all the Cal_field in the report and Epicor Table data definition and did not find it.

Which field is giving you the problem? Calc_DspDocLineTax?

That is because the RDD for the Invoice Form has changed. I would just go into the Query and set your field to nothing and alias it as the original field name like so:
Change T2.Calc_DspDocLineTax to ‘’ AS Calc_DspDocLineTax I’m sure after you change this one a few more will pop up, just do the same.

This issue is stemming from the report definition in Epicor. We just went through this issue during an upgrade and our consultants and Epicor Support were absolutely no help.

We had to go through and manually add every error’s needed field to the data definition one at a time and it eventually worked.

Does the standard version run?
We had the same issue and manually added the fields to the data definitions, but during the next pass it was fine and we didn’t need to manually add the fields. We had this problem with AR Invoice, Sales Order Ack, and Purchase Order printing.