Stuck on Classic View

I have some users who are stuck in Classic View when it comes to the main sign in page even though they check the “Kenetic Homepage” checkbox on sign in.

What should I look for to get this fixed?

Is it set up that way in their sysconfig file on their client or the target path options on their shortcut on their somputer?

Nope it is not! That is why I am so confused.


Did you try deleting their personalization using personalization purge?

What values would I remove from the personalization purge to fix a homepage issue?

I just tried deleting MainMenuLayout and MainMenuHistory and that did not work.

All other personalizations were in relation to a specific form, not the homepage.

Those were the two I was thinking of. I would clear cache if you haven’t done that already.

Also, are you on E10? Or is this Kinetic?

I tried clearing the cache. That did not work either.

I am on 10.2.700

Have you tried re-installing the client altogether?

Just did! Still nothing :rofl:

I think Ill just toss it over to epicor support. I appreciate the ideas though!

Check in your sysconfig. From ‘back in the day’ when the home page was new the logic was designed to fail over silently.

<HomePageUrl value="" />
    <AppServerURL value="" />

If your HomePageURL value is empty it will default back without error or warning.


Patrick I was going to comment that but had no way to back that up haha! I could’ve swore I saw that it silently failed, but didn’t know how to tell Kyle to look for the failure or where to look for it!

Unfortunately my HomePageUrl value is not empty. I can resolve to this webpage from my browser as well.

Alright well this is strange…

Signed in using another users account, loaded correct homepage.
Signed in using my account, loaded the classic
Signed in using my account again, but unchecked the Kenetic homepage checkbox. Signed in classic.

Last time signed in using my account and rechecked Kenetic hompepage and now it works…lost for words.

1 Like