Subreport Location

Struggling with subreports a bit. To find my subreport and add it to my main report, I am going through the browse option:


This becomes a long URL as I have to find my report through the report server. The only way Epicor will let me upload my RDLs is by putting my subreports in that file path within my report folder. For example in this case my main report is in reports/CustomReports/DropShipPS and my subreports need to be at reports/CustomReports/DropShipPS/EpicorERP/reports/CustomReports/DropShipPS for me to be able to upload them. We have plenty of reports where the subreports and main report are in the same folder, but can’t quite figure out what the issue is here. Any ideas?

We just enter the name of the subreport file without using the Browse. This allows us to keep the subreport in the same folder as the main report. When I upload the report files using Report Style maintenance or the SSRS Report Builder screen in Epicor, it automatically uploads the subreport as well.



1 Like

So I did try this, but there were two issues. The subreport parameters were not recognized by the main report, so I wasn’t able to pass anything, and Epicor wouldn’t let me upload because it wanted the subreport to be in that subfolder for some reason.

We have to add the parameters in the parent report manually. In the Subreport Properties window, under Parameters, you can add a new parameter with a custom name - this needs to match your parameter in the subreport. Unfortunately it doesn’t pull the parameters automatically.


What path is Epicor looking for when you do the upload? On version 10.2.700.26 (our current version), it will pull the subreport file from the same folder the main report is in if you only enter the name of the subreport without any folder path.

Ok maybe I was looking at this wrong. My subreport was erroring and I was assuming it was because the parameters weren’t pulling in properly, but if manually entering them works for you maybe I need to try that again and see what happens.

I don’t know what I did differently from Friday, but doing it your way seems to work now. Confused but thank you!