Suppress Epicor MES Message

,

Does anyone know how to suppress the “A Previous Operation has not completed” message on the MES. We have our own custom message which runs under certain circumstances. Depending on what the users have done, both messages keep popping up.

I have found from a trace that it is vMessage Parameter that is returned from BO.LaborImpl but am unsure how to suppress it.

When ever i have needed to do this sort of thing before there has been an argument that can be set.
1 = on 0 = off but have not been able to find one for this. Or am i looking in the wrong place.

You can control this on the BOO of the part.

By default, operations will be set as ‘Finish-To-Start’ meaning the pervious operation has to be complete before the next can begin.

image

You can modify this setting accordingly if an operation can begin before the pervious operation is complete, and Epicor will not give you that warning.

You can disable the warning in Shop Warning maintenance. We have it under Production Management > Job Management > Setup.

2 Likes

Thanks Tyler. That is exactly what i needed.

Hi Stuart,

We’re not using shop warnings but curious about the screenshots. In general what do they do?

Thanks

Hi Matt
It depends on how you are using Epicor but in general there are a whole series of warnings that pop up under various circumstances in production, Job is over efficiency, Setup is not complete, Job is over quantity.
But they are just notifications. They can be linked to alerts, and show in the Edit lists or shop tracker.
You can configure the alert through shop warnings so it will not pop up but will show in shop tracker instead.

We have a lot of the warnings running via BPM’s The BPM’s are set to fire under various conditions and set to error instead. So they stop the process dead if the correct process has not been followed. With the shop warnings switched on, they keep firing which means the user gets two messages. The custom ones and the ones generated by the system.