System Task Agent Won't Process

Okay, I have an interesting conundrum, mystery if you will. This is just a Test database I created in Azure.

I have a test server I created in Azure. I copied a Live database to the new Azure database. I setup the App Server in Azure and created a Task Agent. This is a typical Net.Tcp Endpoint Binding: UsernameWindowsChannel. I will add that I upgraded the database from a 10.1.600.9 to a 10.1.600.38.

I created the Task Agent in Epicor. AppServer URL’s match. When I enable the Task Agent on the App Server, the Task Agent in Epicor starts.

The Problem:
I can’t generate reports or process anything like MRP or Production Planner Process. I get the error below:

EpicorLive10: An error occurred trying to run task ID 491221 for agent SystemTaskService on the application server (User: MyUsername, Task Description: Job Traveler).
Error Detail:
An error occurred while updating the entries. See the inner exception for details.
Stack Trace:

  • at System.Data.Mapping.Update.Internal.UpdateTranslator.Update(IEntityStateManager stateManager, IEntityAdapter adapter)*
  • at System.Data.Objects.ObjectContext.SaveChanges(SaveOptions options)*
  • at Ice.IceDataContext.SaveChanges(SaveOptions options) in C:_Releases\ICE\3.1.600.38\Source\Framework\Epicor.System\Data\IceDataContext.cs:line 352*
  • at Ice.IceDataContext.Validate[TLinqRow](TLinqRow row) in C:_Releases\ICE\3.1.600.38\Source\Framework\Epicor.System\Data\IceDataContext.cs:line 311*
  • at Ice.Security.UserActivityLog.LogonFailedLog(String companyID, String userID, String message) in C:_Releases\ICE\3.1.600.38\Source\Framework\Epicor.Ice\Security\UserActivityLog.cs:line 73*
  • at Ice.Manager.Security.LogOn(IceContext dataContext, String userID, Guid sessionType) in C:_Releases\ICE\3.1.600.38\Source\Framework\Epicor.Ice\Manager\Security.cs:line 507*
  • at Epicor.Hosting.CallContext.Create(Operation op) in C:_Releases\ICE\3.1.600.38\Source\Framework\Epicor.Ice\Hosting\CallContext.cs:line 173*
  • at Ice.Security.AuthorizationManager.CheckAccess(OperationContext operationContext, Message& message) in C:_Releases\ICE\3.1.600.38\Source\Framework\Epicor.Ice\Security\AuthorizationManager.cs:line 75*
  • at System.ServiceModel.Dispatcher.AuthorizationBehavior.Authorize(MessageRpc& rpc)*
  • at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)*
  • at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)*

Inner Trace:
String or binary data would be truncated.
The statement has been terminated.
: at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction

I did think it had something to do with the Task Rules. And I did find that the copied database did bring the old Task rules over. I deleted those and still no joy.

Any ideas?

Jonathan Lang

1 Like

Check this thread as a copied database needs to have a few elements edited/deleted form the Sysagent/Systask tables in order to connect to the test/dev task agent service.

1 Like

Yeap, that was already done. No active status in Ice.SysTask.

Inner Trace:
String or binary data would be truncated.
The statement has been terminated.

Typically refers to the data trying being assigned to a field that has a smaller size.

The problem has been solved:

Workstation Method can’t be **Default. **

This seems to be an issue with 10.1.600.x

1 Like