Textbox within a group box (or whatever it is called in Kinetic)

Does anyone know if I can delete a single textbox from this grouping?

This is on Job Entry and is a native control.

I would like the JobHead.PartDescription control to be multiline, but it is a text box and not a “text area…”

Another question, am I able to add a textbox to this native grouping? I tried, but can’t get it to insert there.


Yes you can delete whatever you want, just click the trash can icon. But I don’t know what it will break. I usually just hide things in case I decide I want to bring them back later.

As far as adding a control, also yes, but there are two issues I ran into. One is, its extremely unclear what layer a control is actually on. Sometimes it looks like you are editing the layer where you should be able to modify it, but actually those things are on a different layer. I wish you could click on the control properties and see the Parent Layer, just like you can in visual studio.

The other issue I have a PRB pending (not accepted by development yet). I really only ran into this when I was trying to drag controls into an empty container but just in case.

The Problem Case Number is PRB0254815, and has the following Description:

PROBLEM DESCRIPTION: In Application Studio, the User cannot add a Control, like a Text Box, to a 1 Column Container .

PROGRAM ID: Application Studio

EXPECTED BEHAVIOR: Application Studio should allow the User to drag a Control into that 1 Column Container.

Angie, I feel like I am on the right layer. I am in the Details section for the Job.

It is a native component where they have 3 fields in it. If I click the trash can it deletes all three. I only want to delete the description field…

And on top of that I would love to drag in a text area component since description is multiline.

You might have selected the container and not the individual control. You can tell because if you look at the properties after you select the control, the label text should say description (or whatever control you are trying to select). I found I had to click around a lot to grab the right thing.

1 Like

I feel like I am on it because it has all three bindings in it for all three of those fields (part, rev, and description). I guess I just can’t get rid of one of those fields in the component.

That’s strange, it is like its multiple controls all bundled together on that screen.

Yeah, is there a name for that?

I think its a special control because its actually available to select in the toolbox.

Okay, well here is what I got from support. You have to delete the epi binding and then the control disappears when you preview or launch the app after applying the customization.

1 Like

Good to know!

1 Like