Themes - Help

I got extremely sick of the default theme and color scheme. I like darker skins/themes in most applications.

Anyways, this is my first time, and in Office 2016 I love the dark theme, so I am going off that theme.

This is far from finished, but how do I get rid of the blue background?

The picture below is what is troubling me, usually within hovering over areas it tells me to click 1-5 etc. When I hit C I find no information to where I change the color.

The below is a picture of what it pops up instead

I actually figured this out.

Took a while to realize what these were for (I knew the blue green red and yellow were the buttons for ie: credit hold, closed, etc) but I overlooked the Default_Epiform.


it’s slowly getting there.

1 Like

Also can be very handy to have the theme change based on company. There is an Answerbook (6153ESC) with instructions. Good way to keep folks from working in the wrong company.

My clients typically used this to make the difference between Test and Prod very obvious. For example, at one customer we had their logo as a watermark background in Prod, and for Test we had a different background color and put the word “TEST” in big bold letters across the top. We also set up a process to pull the theme from the server automatically so we didn’t have to touch each PC.

I’d be happy to share more details if you’d like…



I’m not entirely sure what you mean by change them based on company?
We only have one warehouse and only about 6-7 licenses, so I’m guessing your reply was geared towards a larger based company?

That is a good idea about the Test version having a completely different layout or bold text saying “TEST”. I would have never thought of that.

I don’t think all my coworkers would want this theme, is it possible to set it to default for a few coworkers and not all?

Each client machine has a default.mfgsys text file in the Epicor\Client\config directory (may not be Epicor, it will be wherever you installed Epicor client). You can set the theme in Epicor as default (under Actions in theme maintenance). You can set each client machine to use the default theme, no theme, or “hardcode” a theme.

You can set different styles for test and pilot the same way.


Thanks Sue!
I might have misunderstood, but I’ve tried defaulting just to me? but this code defaulted everyones,
<Style value="../Client\Styles\Office2016.isl" options="shelbie=Office2016" />

Does it need to be value=default and something put in options pointing another theme to me?

I’m tried going to theme maintence>actions>make default but it pops up the below and I don’t want to default everyones.

If you have the office2016 set as default everyone may get it. Try making the standard theme (not sure what that is) default and keep your config file “hardcoded”. Or…try changing the config file for a user that doesn’t want your theme to None for the style option. Either way should work.


I’m not able to figure it out.

Just my 2 cents … But you should use the ConfigEditor program to make changes to the .configsys files.

It should be in the director that holds the “config” folder where the configsys files are. Mine is located:


Edit: originally called the configsys files MfgSys.

Edit #2: the Config Editor window will often pop up behind other windows. Check the task bar or ALT+tab through the open programs.


This is where you set your default style (theme) in theme maintenance.

If you have a default theme set and the client config style is set at , this is the theme you will get. I think the theme Office2007 is the E9 default theme. You could set Office 2007 as the default theme in Epicor for all users. Your special config setting on your machine should cause Epicor to use your custom theme (Office 2016) on your machine. Did this help?

Good point Calvin, I tend to forget it’s there. You can find it under the Epicor\Client directory. It is much more user friendly!

To change just mine do I enter my credentials (log in) and then go to style and change it to one of these? but what do I do after ? I clicked Specify Name thinking I would then give the path name. I am so confused. and logged in and it changed the layout (like if i was to “unload style theme” ) but it was not the Office2016 I wanted (default is the 2007 I believe).

When you set a theme as default using Theme Maintenance in Epicor you are controlling a setting for all Epicor users. When you use the ConfigEditor on your client machine you can override the Epicor setting controlled in Theme maintenance. Try entering “Office2016” in the Style on your machine.

It doesn’t do anything, I have the style in the same folder as the others though, and even under theme maintance it’s listed in the search. I’ve even tried Office2016.isl too, it keeps running another theme that is not the actual default (if i was unloading style them)

Ahhh…I’ve never tried to test a setting using the Styling options. Try this…once the theme is created and set as distributable (check the check box in theme maintenance) you should close theme maintenance. Close Epicor. Set your config file and then open Epicor.

I got it I had to put the entire path in the text box, but when I log in under manager it shows the same theme still, but I hope it’s because it’s under my computer, I’m having another co worker test to see if shows on her computer when she logs in, before I say this works

It worked!
She logged into epicor on her computer and it was the default 2007. :smile:

1 Like


1 Like

Please, I would be interesting in knowing more about this. However, I haven’t been able to find Answerbook 6153ESC on EpicWeb or EpicCare. It seems to have vanished completely! I have been going through the Epicor Customization guide and it talks about how to customize it by company, but I can’t seem to filter by which environment I am in (e.g. Test or Prod).

Filtering by company refers to the company ID and not the App instance (Production, Test, Pilot, etc…)

If you’re looking to change the theme based on the App (like a special one for Test), make the theme in production. Then after copying the Production DB over the Test DB, go into Test and set this new theme as tge default.

That’s what I do to give the Test environment a lime green background, so it’s obvious that you’re in Test.