Timeout error configuring automation studio

Good day to you all,

We recently upgraded to 11.2.300.10 and I have not been able to get automation studio running. I get a “Connection failed Timed out connecting to server” error when testing the connection. I have tried setting web service license on/off but still no luck, I have also tried re-creating the API key.

Not sure if something happened after the upgrade but I am also getting an errors from the Task Agent when I try to autoprint about invalid credentials and XL broadcast errors.

Nothing looks out of sort on the server side, unless I am missing something. Has anybody ran into any of these issues ? Just looking for any indication of cause

What version did you upgrade from? Do you have a valid public certificate selected on your app server?

We were at and we do have a public certificate selected in our server

What binding are you using? Can you connect to your app server in the admin console? Is your task agent using the same credentials? Can you pull up kinetic using the browser vs. the client?

have you whitelisted workatos ip so they can access your on prem environment?

Appreciate the help Alisa.

I have HTTP/HTTPS bindings (I did just see there is no binding information for those two), I can connect to the app server from the admin console, should the task agent be using the same credentials (it is not currently)

I don’t think it has to, but the task agent credentials have to have session impersonate credentials. Can you log in using the task agent credentials?

Hey Devin,

I dont have firewall access but I did send this workato link to them earlier, IP allowlists | Workato Docs. Do you happen to know if the rules have to be in/out or both and its 443?

we only allowed in 443 and it seemed to work after that.