TreeView Node Issue

I have a custom TreeView that contains several UDTables. Each node you’ll see in the screenshot below represents a UDTable record. The problem is, I have parent nodes that have children, but some nodes aren’t showing as expandable with their children nodes. Only the first row shows they have children. In the screenshot below, you’ll see the nodes highlighted in blue show expandable nodes, but the nodes in orange, also have records and should be expandable, but they’re not.
image

What’s crazier is, if I switch to the records that aren’t expandable at first, using controls in my screen (not the tree), it looks like the tree refreshes and shows the nodes are now expandable, but the other rows that were just expandable aren’t anymore:
image

I tried MyTree.Refresh; and others, but I’m not getting anything to work. On native Epicor screens, each node that has child records is expandable right off the bat. For some reason, my custom screen isn’t doing that. I appreciate any insight. Is it the weekend yet!? :slight_smile:

Are you using a different UD table for each tier?
What call are you using to select the nodes(using the other controls)? What does calling ExapndAll() do?

1 Like

Hello!

Correct, each tier has its own UDTable.

The other controls seem to affect the tree nodes, populating the child nodes as described above, but when I click around on them in the tree itself, nothing happens. To clarify: The DataViews change as I click around the tree, but the tree itself doesn’t do anything. If I put an ExpandAll(), it does expand the nodes, but only for the records that show as expandable (i.e. the nodes I highlight with blue boxes above) the other nodes which do have child records, are still not expandable (orange boxes).