Unable to Connect Kinetic Application after create

Dear All,

I have installed and configured Kinetic Version )Kinetic 2022.1) with UD (UD11.2.100.5).

1.Created Demo Database
2. Tried to Create Application Server with Demo Database. After Deployed getting below error while connecting Application.

Error Message:
Unknown REST exception:

IIS 10.0 Detailed Error - 500.19 - Internal Server Error

You will have to look at Windows Event Viewer and IIS logs to determine what’s happening.

no event generated

Its tough to diagnose there could be so many reasons.

We would need screenshots from your Admin Console, Admin Settings, IIS Settings, SSL Cert, Binding Settings…

I have no issues - I had issues in 2021 with the SSL Cert and I had to do it myself.

It also could be that you have something else listening on port 443 and you are connecting to non-Epicor https…

It could be that you have .NET Core Runtimes missing etc…

Please Note : - I am using Standalone CA for Certificate


For your information,

As per installation guide they mentioned IIS Features - Performance - Static Content Compression only but it is required also Dynamic Content Compression.

On Windows Server 2019 it is mentioned in guide
Application Development:
l NET Extensibility 4.8
l ASP.NET 4.8

but on server it is showing 4.7

IIS Log :-

2022-06-29 12:41:09 ::1 POST /ERP11Demo/api/rpc/Ice.BO.UserFile/GetUserFile - 443 - ::1 - - 500 19 13 0

Did you figure out what is causing this issue? I’m seeing a similar issue

Not yet.

It appears that there was an update for both dotnet hosting (from 6.0.5 to 6.0.7) and dotnet sdk (from 6.0.300 to 6.0.302). I uninstalled the old versions of both and then installed the SDK followed by the the hosting bundle and now it works. FWIW I don’t believe it was necessary to change versions since I have the older version working on a different server so it seems the reinstallation fixed it.

1 Like

I have installed both latest version and now it working.


1 Like