Vantage Connection Issue

So, we have the old Vantage sitting in an older server to look back into from time to time and today they went to look and it tells them Unable to Connect to the AppServer. Says the target machine actively refused the connection. Anyone know how to fix this? I am not familiar with Vantage and I nothing stands out to me.

Did you check to verify the appserver is running?

1 Like

Is the Appserver in the Progress tool? If so, I get the same error. If not, Im not sure where it is at to check. Not familiar with this old system.

Yes. The AppServer is in PET (Progress Explorer Tool).

There should be three App services:

  • MfgSys803
  • MfgSys803ProcessServer
  • MfgSys803TaskAgent
    And one DB
  • MfgSys803

I was told the the shutdown of these should happen in the following order
1.App\MfgSys803TaskAgent
2. App\MfgSys803ProcessServer
3. App\MfgSys803
4. DB\MfgSys

And restart them in the opposite order

When I open the PET i get the following error message:

java.rmi.server.ExportException: Unable to create remote reference; nested exception is:
java.rmi.server.ExportException: Listen failed on port: 0; nested exception is:
java.net.SocketException: Option unsupported by protocol
at java/rmi/server/UnicastRemoteObject.exportObject
at java/rmi/server/UnicastRemoteObject.
at com/progress/common/networkevents/EventBroker.
at com/progress/vj/explorer/ProgressExplorer.getClientEventBroker
at com/progress/vj/util/ProDialog.
at com/progress/vj/util/ProDialog.getActiveProDlg
at com/progress/vj/util/ProMsgBox.show
at com/progress/vj/util/ProMsgBox.error
at com/progress/vj/util/ProMsgBox.error
at com/progress/vj/explorer/ProgressServer.workingCallback2
at com/ms/lang/Delegate.dynamicInvoke0
at com/ms/lang/Delegate.dynamicInvoke
at com/ms/wfc/ui/Control.invokeMarshaledCallback
at com/ms/wfc/ui/Control.wndProc
at com/ms/wfc/ui/Form.wndProc
at com/ms/wfc/app/Application$ParkingForm.wndProc
at com/ms/wfc/ui/Control$ControlWindow.wndProc
at com/ms/wfc/app/Window.callback

You have Admin rights?

Does PET still launch, but not show any connections to Apps or DB’s? Trying to figure out if the error you gor was that TEP can’t run, or that PET is working fine, but the connections/configurations of the Apps/DB are bad.

I am logged into the server as Admin. It opens, gives the error, hit continue, and it shows the name of the server with a red dot by it.

I’m going off of memory (been 3 yrs since we were on V8/Progress) …

Can you right click the Server with the Red do to see if any menu pops up. Maybe there is a “Properties…” or “Connect…” option.

If not, what is on the menubar (Where File, Edit, etc…) would be? Anything there look like a “Properties” or “Connect” option?

There is a properties option. It has Server User Password, all of which are correct. Advanced has a server Port number but it is not zero like the error says.

The port is probably 8303 (or 8003 if still on Vantage 8.0).

Any changes to the firewall on that machine, or elsewhere?

No, this server only houses Vantage. I probably do need to check to see if my IT team updated the antivirus as that may of caused some havoc.

For whatever reason, its not actually reaching a port, and keeps trying to listen to port zero.

Well, that did not work. Same error!!!

Not sure if your PET looks like the following, but can you try adding a new Progress Server? Maybe note all the properties of the current local host first.

image

Edit

I haven’t read all of the following link, but it looks familiar. Might hit on your problem, or point you in the right direction
https://www.maine.gov/labor/lmis/win-202/downloads/Documentation/HTML/print/print8ServerInfo.htm

Maybe the best refernce …

At a minimum, you can search the Progress site for your problem

In that rticle it says, “C:\progress\openedge\bin\promon.bat [path to the database]\win202.” what would the path be? Meaning how is it typed in, if guess is the bet way to say what I am trying to say.:roll_eyes: Kind of confused on this part.

I’d take that to mean the path were the file (or folder) win202 is.

In other words,
C:\progress\openedge\bin\promon.bat is the dos command to execute (happens to be a batch file).

and
[path to the database]\win202 is a parameter passed to that batch file

If win202 was a file in c:\epr\sys8\xyz\ then the command line would be

C:\progress\openedge\bin\promon.bat c:\epr\sys8\xyz\win202

EDIT

Now that I’ve looked at the maine.gov page, I think WIN-202 is actaully a server name used by some department of the state of Maine.

Maybe stop/start your Admin Service?
And can you restart you db/appsservers via cmd?
Ref screen shots…


1 Like

Yours should whatever the path to yopur db file is. Ignore the win202 part

Keeps saying, in CMD, that the path is not recognized. SO I shortened it to Just C:\epicor and it said it is not a recognized as an internal or external command, operable program or batch file. Across form epicor it shows .

Tried the start/stop thing, no avail. Port is correct, still giving me the same issue. Not sure how to restart my db/appservers from cmd though. Can you elaborate.