Version E9 on Windows 10

Has anyone ever tried running version E9 successfully on a Windows 10 machine to run their client AppServer application?

If you are referring to the OpenEdge or Progress tools no I have not tried that, but I do have E9 client running successfully on a Windows 10 client virtual workstation. I use this to RDP into the system and support it. The system is remote in Singapore.

I believe it might be an issue with Crystal Reports viewer as we are getting an error “Load Report Failed” with the detail inner exception of “The system cannot find the path specified”. We did give full control to everyone and it is still failing so we believe it might be due to Crystal Reports.

I’m assuming you are trying to run a custom crystal report? Make sure the path to the crystal report is correctly defined for the report style since it’s complaining it can’t find the path specified.

Where do we review the path defined to the crystal report? Even standard reports, it is displaying the same error where the initial install defaulted the install location of the path.

Report Style/Maintenance will show you where the paths to reports are.

System Mgmt > Company Maintenance > Report Style

Then you can choose which reports you want to look at.
My example below is looking at all the reports for the Sales Order Acknowledgement. The redbox shows the report path for each report style that you have.

We verified the report location but it doesn’t provide the entire folder path. Depending on if the user changed the default install location, there isn’t a way to verify the full path it is pointing to. We are running a stand alone E9 client on a Windows 10 server machine as the appserver client also if that helps.

The path is defined in your sysagent settings. “Most” installs point to a folder path similar to this: \Epicor\Epicor905\Server\

Under that path will be a ‘reports’ and ‘customreports’ folders which house the actual crystal reports themselves.


The folder path is shared wide open but still getting the error. We’re thinking this is a limitation with running on an unsupported OS Windows 10 file permission issue. We only have one non-virtual Windows 10 machine that is running the client on.