We LOVE enterprise search but have a few questions

  1. Why does it take so long to return when doing a partial text search, for example *22345, versus an exact match?

  2. When get a part match, I can right click and see open with programs… why no part tracker available (see screenshot below)? We have limited users with privileges to do part entry. Can we change this somehow?

With regards to performance. Doing a wildcard search will end up creating a table scan, whilst an exact match more than likely will use an index to find the information. Table scans are way less efficient. If you check out the help on your Enterprise search server (opening the properties of the related BAQ and clicking help). There is some detailed information, including how the security works.

As a matter of interest, how many parts do you have in your system?

With regards to the context menu, Did you right mouse on the actual part number link or the heading link? You need to configure like fields in the BAQs for Enterprise search

I hope that helps

Hi Simon,

Thanks for your reply. We have almost 30,000 parts :frowning:
For the context menu, I wasn’t sure which I clicked on, heading link or part num, it doesn’t seem to matter, both bring up same options for which programs to open. I would think that the like field is configured for part num since all of the part programs want to open via context, except for part tracker for some darned reason…

This is probably a dumb question, but how do I see the BAQs for enterprise search? Are they named something particular and avail in BAQ designer?


We are using E9 so I am not sure if they have changed or not in E10, but in E9 you can see the BAQs in use through the Epicor Administration Console.

You can look at the properties of the BAQ for the search by right mouse clicking.

All Enterprise search BAQs have an Export ID or Query ID starting with zES. You can add BAQs as you can see in the screen shot, Of course if you are using the zES BAQs as a starting point you have to copy before you can edit it. So in short they are available in BAQ designer.

If you make any additional changes to the BAQ you would need to delete the BAQ in ES then re-add it and do a Reindex. That is the procedure I used, I am not sure if they are the correct steps, but it worked.

The Help for ES is actually not too bad, you can find it as a topic in the Admin Console Help.

ES has heaps of potential, but needs a bit of massaging to make it really useful.

There is also a good section on wildcards etc in the users guide (about 1 page).

I would be interested to hear from others that have made changes or are using ES.

Enterprise Search breaks down the words into a hash and stores them as integers. When you use a wildcard search xxxx or Patrick for example, what it does is it searches the list of words that have been indexes that match the pattern and then go look I the index for them. because of this, the more hits your wildcard search generates, the longer the search will take. It really isn’t optimized for wildcard searching but it does support it.

The most common cause for slow result sets is security. The index contains all the data that the user account set up in the index definition can see, but that is often more than an individual user can see. The index itself does not care about security when searching, doesn’t even know it exists so the result set it gets back contains all possible hits. Then it starts asking the server for the data to display it to the user - that is where security is applied. I have seen cases where it has to ask the server for thousands of records matching the search until it finds a record the user can actually see. Depending on what you are searching for, the security access you have and how many results there are it can take an unusual amount of time.

If you are using enterprise search embedded in the E10 client - it uses the context menu list you normally get when you right click on something (for example a part num) You can customize the context menu right click options (search for context menu in the regular application help) to include different menu items.

If you are using enterprise search from the stand alone website that list is limited to the context menu options the product shipped with. You would have to hand edit an xml file to change it and because it is not designed to be changed your changes would be lost every time you upgraded - not recommended.

Hope this helps!


1 Like

Thank you very much for the details on how / why the one search takes much longer than the other Patrick!

As far as the context menu, I still have a problem. Please see screenshots. I have Part tracker available on Part field in sales order (picture 1), but then when I use enterprise search and right click from found data for the sales order line (picture 2) I don’t get Part tracker. Therefore, system doesn’t seem to use the same context menu items for Part Field on a sales order. Any thoughts on why? Most people don’t have part entry privileges, so of course the tracker being here on the enterprise search with the open with is important.


That should be working, but there can be a lot of uknowns, I assume this is hte same user? I ask because context menu changes can be personalizations or customizations and it may not be picking up personalizations. it is also possible I"m mistaken but the list is being driven by the data available to it from the context menu logic inside the E10 client and that is supposed to include the customized context menu.

Can you tell me: what version you are on? Also can you try in the classic menu and see if you get the same or different result?

Hi Patrick,

I am working on testing in Version 10.1.500.15. Classic view gave same results (screenshot 1).
However, I pulled up the context menu maintenance to see what’s assigned there, any customization/personalization. I noticed that the Part Tracker was called using process calling ID SVGO0013. I think that this was a default from 905702 version, as I have no recollection of ever assigning this.
For Part tracker context call I changed to assign Process ID OMGO3004 (from order management part tracker) and IT WORKS NOW! I noticed in our upgrade that all of the old trackers that were all in the Executive Analysis folder / Trackers are not there now and only some new ones are in there now. Perhaps the SVG process calling programs were ditched?


Compare your E9 vs E10 license files. Epicor dropped a couple of modules from our license when it was upgraded, had to ask for those modules to be reinstated!

1 Like