10.1.600.10 Menu Maintenance Customizations

Just created a simple customization and tested it and went to change the Menu item to point to the Customization instead, but the drop down is empty.
-I logged out and back in, still empty
-I double checked my customization, correct menu and it’s not WIP and it says it passed.
-re-verified the customization, still not listed.
Checked with colleagues and found out that it seems that none of our customization’s are loading.
I’ve tried creating another customization for a different form and nothing it’s not listed.

Has anyone else seen anything like this?

Did you mark your customization as available to “All Companies” when you were saving it?

1 Like

No but there is only one company.
But I did that and it shows up now.
Can you explain this behavior? It didn’t used to work this way.
What is the intent of requiring it to be checked, isn’t company specific enough?

Is that getting fixed in 10.2?

So to fix all these customizations, do I have to open the customization and do a Save As and Enable All Companies? Or is there a way to change the option on the existing customizations?

5 questions in 4 minutes… that must be a record. :slight_smile:

This behavior in 10.1.600.x is the current correct/intended behavior and there are no plans to change it back to the behavior of pre-10.1.600.x releases. There were changes made to introduce consistency in experiences between our Cloud and on-premise customers.

The official process would be to resave all customizations with the “All Companies” box ticked if you wish to have them be selectable to the main menu.


Thanks Nathan!
I really appreciate your quick response and being part of this forum!
Thanks again!

Small tip, if you can get the all companies check box to be defaulted as checked as intended behavior, I think you would save epicor thousands in service calls. Just a thought.

1 Like

Wouldn’t ice.xxxchunk need to be updated as well?

That a good idea–please feel free to open a Support ticket and request that enhancement. It’s a very reasonable request.

I just tested and you are correct; both xxxdef and xxxchunk need to be updated. My apologies.


No problem!
Thanks again!


I just took the Embedded Customizations course, and in Menu Maintenance the instructor had us go to Actions > Copy to Current Company, which also made it show up. If we’re in a multi-company environment and only want this customization in a single company, would that work?