Adding new field from BAQ to SSRS

So I’m making the painful transition from Crystal, which I loved, to SSRS, which so far has proven to be the least user-friendly software I’ve used in a long time. Now that I have some experience, I’m shocked that the lot of you didn’t start a mutiny when they took CR away…

Case in point…I have a custom BAQ report created that I needed to add a new field to after creation. In CR, you simply reran the report, set the data location and your new fields were part of the dataset. SSRS, not so much…I’ve read a few 15 step ‘solutions’ for rdd mods, but nothing regarding custom reports.

I tried to add the field to the dataset by going into properties>fields and then adding the field name, in this case Customer_Name, but the field never populates when I run the report. What am I missing, and could M$ do anything to make this software more difficult to use?

Thanks for any help.

Edit: I should mention that I have attempted to edit the expression as shown here, no luck, just errors where the customer name should be.

If you using BAQ as bridge to SSRS. You need to select those field needed in BAQ. Then either sync or manually add in SSRS dataset.

They are in the baq, I’ve generated a new report, just can’t figure out how to get the fields into SSRS.

You need to select those field before you create the SSRS. Else you need to sync or manually add in dataset -> properties -> query.

Thanks for the advice.

I would like to highly advise against using the Sync Dataset option inside of the Report Style screen. Always causes nothing but problems.

After you have added the fields into your BAQ, go into the dataset inside of your SSRS Report, then modify the query expression.

Add your new fields into the SELECT clause

Then add the field into the fields section

While it may be slightly time consuming to manually add the new fields into the SQL query inside your SSRS report, you’ll spend less time doing that than correcting the mess that that button creates…

1 Like

Many thanks! It was the select clause I was missing, I was just adding it to the fields section.

1 Like

Hello @rirish,

Could you please mark your last post as the solution please.


1 Like