BAQ/Quick Search, Only Retrieving 50 Records

Has anyone seen an issue with Quick Searches and BAQ’s searches only pulling through 50 records compared to when you do a normal search and select the records that appear, you can get 200 by default

Is there a setting somewhere that i am missing or is this a bug/“Feature” in 2022.2

Are you cloud or on prem? IIRC we had a similar issue and Epicor cloud team made some change sorry not sure what as they don’t tell us specifics about the server-side things they do.

I am on prem, i logged a call with support and they created a PRB but have had nothing back in 2 weeks.

I am just trying to see if its just something i am doing or if there is just a setting somewhere i need to change for it to work

You could see if this helps: BAQ Designer - rows to return - #12 by cchang

Still seems to be the same issue

But as soon as i use normal search and select the records, i get 200

I don’t think this will work, but for giggles go into your BAQ and go to Actions > Execution Settings and add a new line for RemoveTestRowLimit and set the value to true.
If you’re in the new UX, you’ll have to hunt for it a bit as I’m not sure where it is off the top of my head.

Tried for the giggles but still no dice!

How many records is your BAQ pulling in if you run it? Can you send a screenshot of the max number of returned results comments section?

only affects rnning in BAQ designer, it is not the case here.

The BAQ in designer gives the error that its over 10,000 rows

When i use it in Customer Search in Classic, it pulls through 10,213 rows

This is the purpose of the “RemoveTestRowLimit” Execution Setting I mentioned earlier. Use at your own risk, however, because you’ll have a bad day if you create a query with hundreds of thousands of rows.

1 Like

Our issue was a little different, even in BAQ designer and setting “RemoveTestRowLimit” to TRUE was only returning 10rows. I looked at our ticket in EpiCare but they didn’t give details on what they did on the back end.