Number of lines appearing

Hello everyone!

I made a dashboard with the query generated by BAQ. Which is the transaction history.
When I enter a period and search, only 250 lines are displayed.
Of course, since transaction details have a lot of data, I think there will be a limit to the number of lines that appear on Epicor. But 250 lines is too few.
Did I set it up wrong? Can’t I increase the number of lines that appear?

Thank you in advance!

I guess that would depend on any criteria you have and the type of joins on the tables in your BAQ. It is hard to tell without seeing the BAQ.

As Adrian said, its probably due to a bad link. One that should be a left outer join rather than an inner. You can usually figure it out by deleting one table at a time, and running the query again to see if you can see all the records you were expecting.

1 Like

Does BAQ have a function to control the number of displayed lines?
Where are you in the BAQ? Where do I have to show you?
Sorry to bother you. I am a very beginner at Epicor.

In your designer, have you got something like this?

You can control the number of returned rows here…if you would want to.

If I remember correctly, BAQs are limitted to 10,000 rows maximum.

1 Like

And you can remove the test row limit in Query Execution Settings by setting The RemoveTestRowLimit to true like so:

Caution here. Chances are when things are running too long is that it truly is a poorly written query. It’s better to raise the limit bit by bit.

Check on the subquery tab to set the number of rows to return.