Blank out a custom UDF date field

Is it possible to set a custom date field to blank on the screen and save the record as normal?

I have a couple of blank date fields on DMR form tied to UDFs. I input somthing in there and save. Now it cannot be blanked out any more. If I erase the value and try to save it just puts the last date in there again.

This only seems to happen with custom UDF date fields. Is this an oversight by Epicor to not allow the blanking out of custom dates?

Also the underlying database says the field is (datetime, null) which means it should be able to accept null values.

That seems odd. The basic idea works as you need, but since it isn’t working…
Do you have custom code that may be setting it or a BPM?

This has come up again on the RMA screen with a new UDF. No BPMs or anything. once the date is set, we cannot blank it out on the RMA screen.

Hi @smason

if not,

check the initial default value for these UDFs, also open the form in developer mode/ customization and check the edvValue within the properties of this field

Thank you for your reply. I didn’t know about Extended Property Maint before. However both of those spots you highlighted are blank for us.

I’ve also taken a quick screen capture video of this behavior.

It’s like the screen won’t let you save with a blank date, it doesn’t recognize blank as a valid value.

I put a request into Epicor support about this and this is now (thanks to me) a known problem on RMA screen with date fields.

This doesn’t happen on all screens, so far only the RMA & DMR screens displays this behavior. Epicor Support put a problem case in. PRB0218852