Bypass BPM for toubleshooting?

I know there is a way to do this but I forget how. I’m troubleshooting a problem with Quote module and I’d like to open the BASE form plus disable any BPMs that may trigger on Quote, Customer, Part, etc.

I think it’s a slash switch on launching the Epicor client but I can’t remember.

I have always done this by launching the form in developer mode, using base, after disabling all related BPMs. This can sometimes be a headache. Hopefully, someone does reply and there is a nice and handy command-line switch for this.

In your appserver’s web.config, search for
customizationSettings disabled="false"

change it to
customizationSettings disabled="true"

That will prevent any BPMs from triggering, along with other Epicor Customization Framework (ECF) items like posting rules I believe. After your testing remember to change it back.


Does that work in 9?

Web.config I guess not. Stoopid question.

It is a different process. To eliminate BPMs in E905 you’d have to rename the \epicor905\bpmexec\ [slot]BPM where slot is the name of the appserver in question. eg. \epicor905\bpmexec\TestBPM

1 Like

Thanks makes sense.



Awesome, thanks for the reminder. I’ll have to try this after hours then as the issue can’t be replicated on our Test environment.