Cannot access Epicor function

We tasked a consultant to create a nightly email in Epicor. He used a function to implement this. I have a need to edit the function. It was “owned” by him so I changed ownership to me, but when I attempt to edit the function, the Design button is disabled and I can’t seem to find how to enable it?

Is it promoted to production?

1 Like

If it’s promoted to production, you need to demote it before you can make changes.

Also, make sure your user is added to the Functions Power Developer security group.


It actually was not promoted to Production. I promoted it to Production but Design button is still disabled. Using Kevin’s suggestion I then demoted it back and refreshed, still no luck. As you can tell, I am new to Epicor functions.

We had professional services write us a function and they locked it down so we can’t design it. Maybe this is the same for your function.

I tried promoting/demoting/refreshing with no luck. I am a security manager, which if I am reading the help correctly, should give me rights as a Function Admin. But also reading the Help, I wouldn’t have access to run the designer. I found the Function Power Developer security group as you suggest and added it to my user account, logged off and back on to Epicor, but the Designer button is still disabled.

Since you’re not the one who created the Function Library (even though you made yourself the owner), check Security tab to see if it’s shared to a group that you’re a part of

I’ve encountered an issue where if the function was imported as part of a solution then it cannot be edited from the Function Maintenance so that might be what’s happening here.

The fix I found was to remove the library and import it directly into function maintenance. Though you’d need to get the original library export from the consultant if this was the case.

I had checked the Security tab and saw the Share With Group button and shared with an IT_ADMIN group I am a member of but still no luck.

1 Like

Probably redundant, but you added these groups?


Interesting. Unfortunately getting the original library direct from him may be an issue as he recently passed away. He was good about leaving his work on one of our servers, I will see what I can find there, thanks.

Yes sir. Added them all just in case.

1 Like

Send a screenshot of the security tab with that library loaded. Are you multi-company?

No we are not multi-company. I appreciate the offer Josh, but I think I am just going to recreate the function as a data-directive and remove the function all together. Shouldn’t take me but an hour and gets rid of the headache. Thank you to all who offered insight as well. At least now I know more about functions than I did. :slightly_smiling_face: