Can't close sales order

Version 9.05.701

Problem: Sales order release number 28016/1/1 is “open” and cannot close it. The error we get is:

.
.

Our previous incidents show that this then usually fixes the problem:
Do the following:

  1. Make a note of the sales order that won’t close.
  2. Open Epicor / Production Management / Data Collection / Advanced Material Management / Material Request Queue
  3. Sort by the order column and locate the order that won’t close.
  4. Highlight the row and either click “delete” or “process” depending on the situation.
    .
    .

However, it doesn’t appear in the material request queue.

I have noticed that there is a packslip not marked as complete for this sales order release…however i cannot reopen it or edit it.

Any help would be much appreciated.
Thanks in advance.

Try looking for a picked order in customer shipment entry. Under more, picked order see if the order is there.

1 Like

Along the lines of Greg’s post, in order tracker, look at the shipments tab and see if a shipment/Pack ID has been created.
It sounds like there’s a pack for that release and it hasn’t shipped - thereby holding open the release. Either remove the line from the pack (that’ll allow you to open and modify it on the order) or ship it, which will close the release on the order.

1 Like

This looks ok to me?

The sales order/line/release is in “Material Queue Manager” but not “Material Request Queue”…and all of the options are not selectable at the bottom.

What would happen if i applied these 3 SQL scripts? Could i be doing any major damage if i applied them and “forced” them closed?
.
.
update OrderRel
set OpenRelease = False
where OrderNum = ‘28016’ AND OrderLine = ‘1’ AND OrderRelNum = ‘1’ AND Company = ‘Prior’
.
.
.
Update OrderDtl
set openline = False
where Ordernum = ‘28016’ AND Orderline = ‘1’ AND Company = ‘Prior’
.
.
.
Update OrderHed
set openorder = False
where Ordernum = ‘28016’ AND Company = ‘Prior’

Already tried an updateable BAQ / DMT?
Sometimes SQL is your only option but bypassing business logic can end up biting you.
Either way, I would almost always copy live to test and verify updates like this.

I wonder if you can UBAQ/DMT the PackSlip as “complete”… if that would clear the error on the order?

Thanks Bruce,
i’ll see if i can DMT on Tuesday

Mark,

We have seen similar and this is generated because of the the fulfilment workbench. From Sales Order Entry go to Actions | Reserve / Allocate and on the Fulfillment Workbench go to Action/ UnReserve and Unallocate .

We don’t get this very so I spent time teaching folks to fix rather than finding out why it happens but most likely will be where quantities don’t match up.

Hi James, sadly that order doesn’t appear when i go to fulfilment workbench

Also,…DMT didn’t work

After doing the following i was able to close the two sales orders.

  1. Went to the “user security” and loaded manager (who i was signed in as)…went to the company tab and ensured that an employee was assigned in the employee field…i selected myself (Mark R)
  2. Went to employee maintenance and loaded Mark R…and ensured the following tick boxes were ticked. “material handler”, “shop supervisor” “shipping / receiving” “production worker” “can override allocations”.
  3. Now when i went to Material queue manager (in advanced material management)…the options at the bottom were highlighted to select…I found the sales order in question, assigned Mark R and clicked save and closed.
  4. This then put the entries into “My selection” tab on the Material Request Queue (in advanced material management) and i was able to select and click delete.
  5. I could then go to order entry and close the order.
1 Like

I can’t believe I’m the first person to have benefitted from this… but just wanted to let you know I am very grateful of your detailed solution. I had been fumbling my way through getting the rights to edit Material Queue Manager and managed to figure that out on my own, but I couldn’t figure out how to get it to show up in the Material Request Queue so I could delete it… I hadn’t considered assigning to myself and then checking the My Selections. Brilliant!