Create new BAQ error in 10.2.400.5


Just upgraded Epicor 10.2.300.14 to 10.2.400.5 When trying to create new BAQ this error show up and not letting me to create new BAQ. Old BAQ is not working either, i’m not sure what i’m missing. any ideas?

Application Error

Exception caught in: Epicor.ServiceModel

Error Detail

Message: Parameter should be specified
Parameter name: systemCode
Program: Epicor.ServiceModel.dll
Method: ShouldRethrowNonRetryableException

Client Stack Trace

at Epicor.ServiceModel.Channels.ImplBase`1.ShouldRethrowNonRetryableException(Exception ex, DataSet[] dataSets)
at Ice.Proxy.BO.BAQDesignerImpl.GetFieldList(String dataTableID, String schema)
at Ice.Adapters.BAQDesignerAdapter.GetFieldList(String tableId, String schema)

This might be related …

Thanks Calvin, I don’t think it is related as I have upgraded to 10.2.400.5 not in 10.2.300

Hi snguyen, did you happen to solve this issue? I have the same issue right now in 10.2.400.11

Hi Fermando,

Unfortunately no. We are waiting to upgrade 10.2.500 version instead

I am not seeing the issue on 10.2.400.10 - Is there a special table you are using? Please report it to Epicor, the more we have reporting it the more can fix stuff…

It was something related to the Conversion, some tables were having weird data and the Conversion Workbench Process for BAQs failed, i had to open a support ticket and they applied a Data Fix, re run the conversion and it passed, everything worked after that.

Just installed 10.2.500.3 and am getting the same error. So, it appears this issue has not been resolved. I just submitted it to support.