Create open BAQreport in CustShipEntry using application studio

Your best bet is to open Dev Tools to find out if it’s tossing an error.

1 Like

Thank you @hmwillett , it’s resolved, I just misplaced the order of events that were there. My next question is how do I send the packnum paramater that I am opening in the shipment entry so that when I print the report only the packnum is printed.

Passing values to app-open tile - Experts’ Corner - Epicor User Help Forum (

Thanks @hmwillett i will try

I’ve made a json script like this.

next how do i make ssrs accept those parameter throws?

I want the baq report options to be automatically filled with the packnum I open

can you help me with this, I’m stuck @hmwillett

Launching App

Receiving App

I’m trying to open a BAQ report from a Kinetic MES environment, but struggeling. I think it’s because I can’t find the BAQ report in my MetaUI folder. Is there a way to generate the neccessary folder from the classic BAQ report?

Instead of putting the MetaUI folder as the app to open (View), set it as the MenuID from within Epicor.
If you haven’t created a menu item (doesn’t have to be visible, it can be under PROCESSES), you’ll need to do that first.

Access not allowed. Error when launching app from button with App Studio - Kinetic 202X - Epicor User Help Forum (

Thanks Hannah, got it :slight_smile:

1 Like

To continue BAQ report fun;
Is it possible to lauch ‘printpreview’ directly after opening app with the necessary parameters?
I tried to set ‘printpreview’ as next-event, but somehow it doesn’t get the trigger after custom_after_OnWindowLoad has been triggered to set the parameters.


Track the events that are called in Dev Tools when you manually do a print preview and copy those including their values.

I did that and ‘printpreview’ should be the only method to trigger.
I double checked it by adding a button that only triggers ‘printpreview’


What i miss is the Dev tools view when opening an app from another application. CNTR+ALT+8 can only be triggered after the method to autoprint is already triggered. :frowning:

There’s a setting somewhere where it’s turned on everywhere by default. It really slows down the system, but it’s quite useful for things like that. Lemme try and recall where it was.

oeh that would be nice! thanks alot!

That’s on the server located in: C:\inetpub\wwwroot<AppServerName>\Server\Apps\ERP\Home

You only need

"ep.metafx": {
   "debug": true
1 Like

Thanks, I’ll ask Jos to change this setting on the server :+1:

This has been so helpful in adding a report to our MES screen! Thank you

thanks so much for the sample. i tried and it worked.
i even asked Epicor application studio expert but he did not know that. thanks a lot,