Custom fields ending in "_c" not showing in BPM table

,

I have added some custom fields in the JobHead table, regenerated the data model, and have been using these fields for a while now. I needed to go in and verify when something was changed in the ChangeLog and I’m unable to see these fields in the ChangeLog. I also was planning to set up a BPM to update another new field (that I haven’t added yet) with the date that the field is changed. Seeing as I can’t currently see the field that I want to monitor in the BPM table, how would I go about using it to set up another BPM to update a new date field?

You need to regenerate your data model again, followed by an IIS recycle, and make sure to restart the task agent as well. Sometimes the task agent can hold onto an old data model if it’s not restarted.

1 Like

I’m pretty sure I’ve restarted the entire Epicor system (SQL and App servers) since then, but I will try your steps specifically and let you know.

I have tried regenerating the data model, IIS recycle, and restarting the task agent several times and it doesn’t appear to be working.

If you open the UD column maintenance, does that table show synched?

No and I’ve tried to get it to sync multiple times.

Do you have more than one app server?

No, but I have 2 app pools pointing to the same DB and I have recycled both. One is single-sign on and the other is not.

Are you stopping both app pools before you regenerate the data model?

@EpsilonMaximus68Olds You can update using joins on ForeignSysRowID from the main table to the UD, but it should just show up.

The field shows in a customization, other bpms just not in a changelog? Do you see it in the dbo view in sql?

Yes, I have stopped both app pools before regenerating the data model.

I had not thought to check the Method Directive. They do show up there, but not in the Change Log. I guess it doesn’t really matter, but just annoys me that it doesn’t work as expected.

Did you look in the DD for the table ending with _UD? (Jobhead_UD)

Edit

The above is bad advice. DD’s use the base table name (without the “_UD”)

What is the DD?

Data directive. They are on tables, where as MD (Method Directives) are on BO’s.

Whoops… The _c fields appear in the base table in a DD. At the very end.

Mine don’t show up. I can see a couple of the _c fields that I’ve created, but not all of them. The most recent ones are not showing up. even after several attempts to Regenerate the Data Model, recycle IIS, restart the Task Agent, restart all of the Epicor servers (App and SQL)…Nothing seems to fix it.

Do they (the missing ones) show in other aspects of a DD, like in the tree pane of a Set Variable widget?

One last thing… It appears that UD fields can be made company specific. There are some fields not shown on the Extended UD Maint form (like Company - which is normally blank). I’m guessing this is how a multi-tenant system keeps you from seeing other tenants’ UD fields (not the values, but the fields themselves)

Yes, they show up in the Set Field widget.

Very weird indeed.