Customer contacts not showing up on Customer page after trying to DMT them in, but everywhere else they look okay

I started here,

and still wasn’t sure about the file format so decided to DMT the customer contacts in. Did a single test one first, which i may have assed up:

The first time I did a test dmt, one contact to one customer, I had bad data, as I had misinterpreted the meaning of ConNum thinking it was perconid, doh:

Company ConNum CustNumCustID
KNZ 1592 1016

Subsequently ran it with (what I think is) correct data:

Company ConNum CustNumCustID PerConID
KNZ 0 1016 1592

I’ve checked via sql table erp.custcnt and there don’t appear to be any records with the wrong ConNum, in particular none with ConNum =1592.

Looking at custID 1016 that looks correct:

select c.CustID,cc.perconid, cc.* from erp.custcnt cc
join erp.Customer c on cc.custnum=c.custNum and cc.Company=c.Company
where c.CustID='1016' and'KNZ'
CustID perconID Company CustNum ShipToNum ConNum Name
1016 1261 KNZ 259 1 Pete
1016 1592 KNZ 259 2 Test Tester

As far as I can tell all is as it should be here. But contacts just do not appear:

Yet again when I look at the person contact links (eg percon 1592, Mr “Test Tester”):

Any thoughts as to what might be wrong, or how to diagnose this further?

Oh and important FYI, this is broken on ALL my customers now, none of them are showing contacts, despite me only dmting to one of them.

It looks like that is a screenshot of a custom layer? (preview) Have you confirmed the problem exists in the standard app?

On the DMT side of things… I don’t think it liked your ConNum value of “0”.

I think its terrible that ConNum is a required field. It should be a system assigned value… BUT… I suppose the ConNum may be needed with DMT if you were “updating” versus “adding”.

When I did our initial Customer Contacts DMT once upon a time… I had to write an excel expression to give me a running count per CustNumCustID for each contact.

See below image (I hid all the detail columns) but this should show that each time the CustNumCustID changes… the ConNum restarts at (1).


As for why they’re not showing on the Customer > Contacts screen… I’m not sure about that.

I’ve DMTd contacts with contact num 0 - that lets Epicor assign the connum.

You are correct this is a custom layer, however its broken the base unmodified Customer menu entry also. I am wondering however if its app studio related, but have gone back to a “new layer” and preview of that still shows no customers, and Contact data view is empty

Also. You see in my data ConNum was 0 in DMT, but gets set to 2 automatically. ConNum uniquely increments per Company/CustNum/ShiptoNum combination, so don’t believe that’s the issue.

If you manually type in a contact in the customer screen does it show up?

no, but solved it see below. weird.

Solved it I think.

I used dev tools in another older database, where contacts were loading.

There’s a RetrieveContacts event that fires, that does the retrieval, but only if TransView.RetrieveContact is true. On the old db where it was working it was true, on the current db it was false.

Looking at the landing page loading in dev tools:

I also found system events to set this to true or false, though don’t know where the controls “RetrieveContactFalse”, “RetrieveContactTrue” is, I sure can’t see them…

Anyhoo, duplicated this event on my own button, clicked it, and contacts are working again.

Still begs the question: what changed this setting before? Nothing I have done I am sure, I had been DMT’ing in contact data, not playing at all with app studio when it appeared to break.