Dashboard Not Running (for some)

Greetings all! I have another one that is stumping myself and Epicor support. We have the Job Materials Dashboard that we run. It usually takes less than 2 seconds to run it. However, some users are not able to run this and it times out after 5 minutes.

Interesting things to point out, it seems to be user specific. When I go to someones PC that is having the issue and use my Epicor credentials, it runs as expected. I also created a new user that has the same settings as myself and that did not work. I also deleted the 808 folder from here as suggested by our managed ERP vendor. (C:\ProgramData\Epicor\epicorapp01-808).

I rebooted the AppServer and the SQL Server at lunch hoping that would fix it. Nothing seems to be working.

I thought maybe it had something to do with the BAQ, but it works for some users and not others. So it can’t be that right? There is only one level in the query, but it isn’t an intense query.

Any help would be greatly appreciated, and I will buy drinks in Vegas next week if we can get this sorted.

1 Like

Does it not return any data? or does it throw an error? Different user on the same PC works?

1 Like

Jose wants the drinks! Jk, I wish I could help too solely to help you and your users out like Jose is trying to do @epinoob

My poor liver can’t take it as it is, gotta lay off the juice! :grin:

1 Like

Is there security on the BAQ?

It times out after 5 minutes.

yes. I remoted in the affected users PC and used my epicor creds and everything works just fine.

This BAQ worked for years and just now broke. Nothing was changed, and nothing has been updated.

Do you update statistics on your SQL server? Looks like BAQ just times out.

I have not. Should I?

Do one more test, make a new basic dashboard with the query and try it.

Is there anything in the Event Viewer on the App server?

You can also uncomment this line in the AppServer.Config and it will put the actual query being sent to SQL in the serverLog.

 <add      uri="profile://ice/fw/DynamicQuery/BaqStatement" />

EDIT: The line is in stealth if you don not use grave accents :frowning:

If they have a personalization for this dashboard, delete their personalization in ‘Customization Maintenance’ and then have them log out and log back into Epicor. Personalizations tend to get corrupted from time to time, and have been the primary culprit when individual users suddenly have issues with dashboards that other users do not.

I checked and they do not have customizations on that dashboard. Oddly enough, now our weekly sales analysis dashboard is having the same issue. Management is gonna be pissed at that one!

I did already try this. that also didnt work. I am out of class at noon today in vegas if anyone wants to nerd out with me in my room. I know that sounds strange, but you know what I mean.

Have you tested running them as assemblies rather than runtime?

What eventually worked was running the Hallengren Index and then the sp.Blitz. Not sure why, but that fixed it.