Dashboard Not Showing All Tabs - Help Needed

We have a dashboard with multiple tabs on it. The issue is that when that dashboard is added to a menu item it only shows one of the tabs not all of them.

Any ideas on how to get the other tabs to show?

Is it similar to this post Blank tab title on dashboard when Deployed or are they not showing at all?

They are not showing at all. Also noticed our tracker is missing in action. The tab shown says summary at the top.

Hmmm, that’s odd. So its only happening when deployed on a menu item not on the dashboard itself? may be worth trying to redeploy it again and see if that fixes it.

Yea, in the dashboard module it shows everything just fine. Just tried a redeployment, a new menu item, and an Epicor restart to be sure. The issue persists.

Just an idea… Make sure you publish the kinetic layer with your changes.

How do you publish a kinetic layer if its just a classic dashboard?

Oh Yes. I just saw your version was Kinetic, so I missed that it was a classic dashboard. Are the tabs added at the native dashboard level, or at the customization level?

Tabs are on the native dashboard level

Interesting. I can’t seem to replicate it on my end. Can you attach your dbd and BAQ? Have you tried exporting/importing your dash? Have you tried recreating it from scratch?

dumb question, but are you 1,000% sure that you picked the right dashboard to put on the menu?

Also, when you test the dashboard from the deploy menu does it work correctly?

I have tried exporting/importing and making a new menu item. Haven’t tried making it from scratch. Below is our dashboard and baq.

EA_OpenPOs.dbd (428.3 KB)

I’m 999.99% sure I am selecting the right dashboard. When testing the dashboard it shows correctly.

Can you try opening it up in developer mode (like for making a customization) sometimes that kicks the cache to get updated.

That didn’t seem to do anything.

Forgot to ask earlier, are you the only user that cant see the other tabs and tracker view? Have you tried clearing the cache via File Explore?

I imported your dash and it looks fine on my end. I didn’t test any functionality, but I see all three tabs and the tracker frame at the top with all of your combo boxes. I would suggest deleting your dash and BAQ, then reimport the one you just exported.
Good Luck!

For what it’s worth, I’ve had a similar problem, and saving with a new name and re-deploying worked for us. Usually happened with dashboards that were re-deployed multiple times in a relatively short period. Had to be a brand new name though.