Dashboard Trackers not working

Has there been any update to this topic?  I ran into a similar problem as well.  I ultimately had to program in a refresh, followed by an autoclosing MessageBox prompt.


I have been making various dashboards for our company and have run into an issue with them:

Every time I add a tracker to a dashboard it doesn't work anymore. For example, when I add a date range to the tracker, once I enter a range (and I know data fits the criteria of the range) and hit the refresh button, instead of the dashboard only showing the data that fits within my range it does nothing. If I hit the refresh button once more the entire grid goes empty.

This happens for any type of prompt I add to the tracker. Whether I add the prompt using the tracker customization tool, or I add the prompt using the default tool... I have the same result.

I have spoken with Epicor technical support and sent them my dashboard definition with the BAQ's attached and it works fine on their server.

Has anyone else had an issue like this?

Good Morning,


What version of epicor are you using? 


We have found issue with summary queries on dashboards not allowing application of filtered data via tracker view (version 905702).  Additionally, in earlier versions, we found that trying to apply data filter to calculated field data wouldn't work reliably (9056xx).  Other than that, we have our tracker filters work, runtime dashboards and dashboard assemblies.


I'm sorry to say we never got a fix and instead "design around" these disappointments.



Good Morning,

Thanks for responding. I am using Epicor 9.05.702A.
I was on the phone with technical support most of the day yesterday and came to the conclusion that it is due to running a SQL server and using calculated fields. The BAQ I built used the QuoteHed, QuoteDetail, and QuoteQty (toggled as a summary table) tables. I was pulling the min quote qty and max quote qty as well as their respective unit prices and then using a calculated field to show the extended total. The BAQ worked fine and was able to pull the data and make the calculation, but when I applied a tracker in a dashboard the grid would go blank. 

I exported the Dashboard definition and BAQ's and sent it to Epicor Support and it worked fine on their server because they use a progress server, but we use a SQL server so every time I applied a tracker the grid view would go blank when I refreshed.

Unfortunately, like you said there is no fix as of yet. The technical support member I spoke with said she would send out a bug request to the programming team, but in the meantime I have to use crystal to make the calculation and then attach the report to the dashboard.