Data Discovery install Error on Clicking New

I am trying to build up a demo install of, and at the final step installing Data Discovery I am getting an exception Sayin that the DatabaseUser colum in the Application server settings is Null. I have looked at the Ice.ApplciaitonServerSettings table and it is indeed null. Interesting in an 10.2.200 version I did last night I didn’t have any issue.

I see on Epicare there is a problem PRB0168701 which refers to exactly the same error and scenario, but it mentions it is about the SSRSCreateDatabase field. Unfortunately it does not give any resolution even though it is closed.

It may be the way I installed things as I installed 10.2.200 on the server last night and then had to install 10.2.100 today. I did have a few issues with the admin console but it appears to be functionting correctly.

So if anyone knows how to get around this problem I’d appreciate it.

  1. Navigate to C:\ProgramData\Epicor\SetupInfo .
  2. Open the [nameofyourapperver]SetupData.xml in your text editor of choice.
  3. Locate the ApplicationServerSettings block.
  4. Do you see DatabaseUser? If not, it is really saying that it doesn’t know which user to use to connect to the Epicor database. If you are using Windows authentication, you can just add the opening and closing tag for it.
  5. If this section is missing, your best bet is to create a new appserver from the EAC with exactly the same values as this current appserver with the exception of the name of the appserver process, deploy it, copy this section from that new setupdata.xml file and paste into the existing (changing the relevant values).

Here is everything within the ApplicationServerSettings block.

<AuthenticationType>SQL Authentication</AuthenticationType>
<SSRSDatabaseUser />
<SSRSDatabaseUserPassword />
<SharedAssemblyDir />
<SSLCertSubjectName />
<DNSIdentity />
1 Like

Thanks Nathan. Much appreciated.


This is what my Setupdata looked like:

<AuthenticationType>Windows Authentication</AuthenticationType>
    <DatabaseUserPassword />

Turns out the whole data discovery section was missing. Got that sorted, but was still getting the errors when I clicked on the New button.

I went through every key and tested, but no change. I ended up trying to populate the values in the XML just as in the installed version leaving the Installed flag set to false, and tried to deploy. It ran, but I got hit with an error, stating a License file was required. :frowning: guzumped!.

Went and ran the msi file for that version and it threw an error stating an newer version was installed, which is the case.

I am safe to assume you can’t have two different version appservers on the same server and run data discovery for both? I am sure I did read that you shouldn’t install more that one version on the same app server, so I am guessing that may be the cause.

I do believe it is one install per server

On your previous comment Nathan. I took the angle of just installing 10.2.100 on another test server I had that had 10.1.600 installed. Somehow I managed to corrupt the Administration console and now when I open the console on the Server Management Node I get MMC could not create the snap-in.

So thinking all I needed to do was uninstall the Admin console and reinstall I get this message.

Error 1001. An exception occurred wile uninstalling. The exception will be ignored and the uninstall will contine. However, the application might not be fully uninstalled after uninstall is complete -> Cannot delete a subkey tree because the subkey done not exist.

I note there’s a problem for this in Epicare PRB0083949, which has been resolved. Just like the other it is resolve, but I can’t tell what the solution is.

I am going to restore this server anyway, but I thought I’d mention it.

One of the things’ I’ve noticed about problems they have the Product version at the bottom, but I don’t know how it translates to the version users see.

Are there any posts or Epicare KB articles that point how users can better interpret the Problems form.

And the saga continues.

Taking a different approach I went back to my other server and uninstalled 10.2.200, and data discover and reinstalled 10.2.100 which worked. I went to add in data discovery and got sidtracked halfway through the install, forgot what I was up to and clicked cancel. It prompted me that no settings would be saved.

I came back later clicked on new and that’s when I got the DatabaseUser error as mentioned in my first post. so it appears if you start the Data Discovery process.

after fixing the XML in the setup info I was able to attempt to deploy, but I keep running into a LicenseFile is required error, even though the install document states
4. If you have an Epicor Data Discovery Basic or Advanced license, enter the License File to identify your company's license for Epicor Data Discovery. If you do not enter a license file, only the Epicor Data Discovery core functionality will be installed.

Interestingly it mentions in the next step to enter in a fully qualified domain name, but that field does not exist. could there be some version mismatch of the admin console?..

Thinking that because the fully qualified domain name field was missing. I thought that there may have been some version issue with the admin console, and that running the upgrade to 10.100.22 was not really going to cause me any more grief at this stage I had nothing to lose.

I had already proven that the client would run at the base level, just with no extensions. I performed the upgrade, ran the conversions etc and logged in. Interestingly this time when I logged in I noticed that the active home page had appeared below the Classic style option on the login screen. I could login with the Active Home Page Yeah…so to press my luck a bit further I had a look at the Data discovery extension app tab and loe and behold the fully qualified domain name field appeared!. I clicked deploy and it deployed and now I have just logged in and results are appearing…

The worst thing is I don’t really know what really fixed the problem. I suspect somewhere along the line the admin console got confused, if admin consoles actually do that :slight_smile:

Time to move on, other fish to fry…

Thanks for your help Nathan, and boy did I learn a lot out of that exercise.