Debug in Visual Studio disabled

I’m trying to open a customization in Visual Studio. I have Visual Studio Professional 2017 installed on my machine. In Epicor I go into developer mode, open the application and am taken to the Select Customization dialogue. I can highlight any available customizations, but the “Debug in Visual Studio” is grayed out, disabled. What else do I need to have set/configured to enable the “Debug in Visual Studio”?

  1. Try rebooting (if you just installed VS and didnt reboot yet)

It should work - also see thread

What version of Epicor?
There are only certain version of visual studio that work with it.

I think the previous post leads to this but check if this key exists in the registry


It does not—does the “15.0” in that entry refer to the version?

We are on

That is not a valid Epicor version…

Doh! Sorry,

15 means VS2017. On a standard install you should have that key.

You can try manually adding that key - but make sure you have rebooted and it still does not exists.

Microsoft Blip:
You can also check simply that VS2017 is installed by verifying the key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\DevDiv\vs\Servicing\15.0\Core@Install is set to 1

I will give that a shot, thank you

No, still nothing. Am I setting it correctly?

Should have added that it did not exist after reboot, so tried to manually add.

Sorry - add like this. Instead of 14 you should have 15

I’m sorry, still no go: