Disable Auto Saving for Sales Order Lines

Hi all!

Is there a way to disable the auto-saving feature for the lines of the Sales Order Entry?
We have 4-5 custom fields on every line and if an order has lots of line, every time that the system do the auto-save we lose about 10 seconds.
Is there a way to turn off this feature?
We would like to save manually after modified every line of the Sales Order.

I came across this post: Order Entry - Turn off auto saving for each line entry, but for me disabling ReadyToProcess (Or ReadyToFullfill) doesn’t do anything. The lines keeps autosaving for every changing.


I wasn’t aware of such functionality, I know most entries save changes after performing certain actions like before trying to close the form or when trying to create a new item it tries to save any current changes.

But nothing like triggering an Update after every field change, not without the user clicking on Save or maybe using a hotkey.

Can you turn on tracing and see what calls are being made for the “auto” save.

With a few exceptions, the Epicor programming model supports a single dirty row and the Client UI framework executes a Save if the current row is dirty and the UI “view” is being changed to a different row or a different view.

The Server code also expects to receive only a single dirty row - UpdateExt is an exception but under the covers, UpdateExt only processes one row at a time. Sending multiple dirty rows to Update may work on some business objects but it will not work on all.

Depending on what you are trying to do (especially if you want to update UD fields on Multiple rows), you may be better off creating an Updateable Dashboard for the Fields you want to update and using the Multi-Dirty row option on that. UBAQ Dashboards work via UpdateExt so could possibly be quicker.

If it takes 10 seconds between each save of a few line order, I would offer that you have a poor performing Customization, BPM, Network, Client, or Server. The first 2 would be the best places to look though.