Order Entry - Turn off auto saving for each line entry

Our order entry menu is very slow. We’re working to troubleshoot the speed issues.
Is there a way to turn off the auto save function that happens after each line is created?

Do you use avalara for tax calculation, you can uncheck Ready to Process until the order is entered. Check when order is entered complete.

Do you have any BPM’s or customization applied?

1 Like

We have a lot of BPMs and Customizations.
I think that one of the BPMs automatically check the ready to process checkbox.

Performance is even worse on PO entry if you leave it on. To prove it take a trace from the client and run it through the Performance diagnostic tool. That will show you where your issues are. More than likely it will be RtP

I’m working to run some trace logs now.
I also have the performance diagnostic tool.

Everything that I’ve sent to Epicor support is considered inside the acceptable limit when it comes to processing time. I need this thing to run faster :slight_smile:

The best your gunna get is turning off RtP…But if you use Avalara you’ll need to do it as some point. In PO entry where were having our issue, Approving does it anyway. Not sure on SO.

Do you have any BPM’s as mentioned earlier?

Yes, we have a lot of BPMs. I’m going to turn them all off in pilot.

Just curious on BO Sales Order, How long does it take to process the MasterUpdate Method?
We’re taking between 6,000 and 11,000 ms to process.

Running on the Demo database Company:Epic06 Site: Evanston RtP:Off RtF: Off 1x partnum 040-3445 Customer Addison

Same Order, but with RtP:on and Rtf on

Which is weird, but I suspect that there is caching going on. The first run was more than like the first time the appserver/pool has been used for a while. Probably need to do some more comprehensive testing as the scenario was a bit contrived.

Do you have a baseline to start with? To be honest the RtP issue for us was around the PO.

I’m thankful Epicor added the Ready to Calculate to turn off tax calculation. Unchecking it also reduces the number of API calls to Avalara and lowers the transaction volume :wink:

1 Like

If you use the Booking records, these are not written until RtP is checked. If you’re not using Booking records, try turning that off in your Sales Config and see if that improves the speed.

1 Like

Do you mean


I stand totally corrected. Thanks for educating me @Mark_Wonsil and @bderuvo

1 Like