DMT Operations Error A Resource Group ID is not valid with the site

DMT 10.2.500.12

I am trying to import Operations into Epicor. I also wanted to set the Resource ID on the Import. However, when I first Process it, it will come up with the error.

PANEL Table: OpMasDtl Msg: A Resource Group ID is not valid with the site.

However, when I press the Process button again, the error will magically go away. The problem is that I want to use it within a playlist, having error will stop the process…

Anyone know the solution will be good.

Does it actually process the second time or does it just think it did?

Clunky as it may seem, but you might need a specific user (set to a specific site) for each site based import. I ran into issues with this myself, fortunately we did not need to automate it. So we did it a bit at time…Have I logged it with Epicor??? Slap me now!

The process will occur the 2nd time you press the Process button.

Specific user for each site based import? You mean log into DMT using different user? I thought that I have authorized myself to access all sites.

I have created a case to Epicor and hopefully this can be resolved. Otherwise, I have to do that part manually. The reason why we want to automate this is so that we can recreate the system from scratch again very quickly by using Playbook feature from DMT.

These steps have worked for me:

Login to Epicor.
Change to the Particular Site you want to import to.
Logout of Epicor.
Logout of DMT (if already logged in).
Login to DMT.
Run the site specific DMT template.

If there’s an easier way I’d love to know, but at least in 10.2.400 that’s the only way I’ve been able to do this.

1 Like

I have a similar issue with this load getting the same error.
The differences are (1) i’m loading across multiple sites and (2) the errors occur on SOME operations in a site - but not all?
I’ve triple check resource group validity within site- and appears good
Operation though the UI is flawless.
Anyone have a similar experience/resolution?

It’s a thing with DMT. I haven’t done DMT on Operations since we went multi-site, but I imagine it’s like this:

DMT is not site aware for particular templates (resource group, transfer orders, there may me more), but is for part combined. I know you can change company in the DMT to default it, instead of including the company field, unless things have changed in later versions.