E10 DMT Error Input array is longer than the number of columns

I’m trying to use the sales order combine to enter multiple sales order lines.

I am able to successfully import the first line however, the second line does not import. I do have the OrderDtl#OrderLine field set to 2 on my second line. Line two always throws the error “Input array is longer than the number of columns in this table” This is a CSV file and I manually entered the data into the form as I’m creating a new order not updating an existing one. I have reviewed it in notepad and do not have any extra columns. I can’t figure out why line one is successful and line two errors out. Anyone have any idea as to what might be going on or how to fix it?

I’d appreciate any assistance! Thank you!!

I am on DMT

I created a CSV file that has two lines and I can import them without any errors. Is there any special characters in the Part Number?

Try moving line 2 to the top and see if the DMT still works.

1 Like

Thanks for the suggestion. I removed the # but same result. No there aren’t any commas in our part numbers, but they do contain dots and dashes.

I even tried putting in line 2 first. Whatever is in line one will import and line 2 always throws the error.

Try setting your orderline to 0 for all lines and make sure they are in the order that you want then to appear in the SO. Let me know your result. I just had a look at my input data and it does have OrderDtl#OrderLine with numbers. What version of DMT are you using? Do you have any bpms enabled?

1 Like

I am not versed in DMT but I wonder what is the end of line delimiter? Different OS’s and even text editors can handle line breaks\feeds differently. When you view a text file, all you see is a new line, so its hard to tell.

Morbid curiousity - does the problem still exist if you use an Excel sheet instead of a CSV? DMT will work with both.

If it does, then perhaps BOM markings and underlying unicode silliness are happening in your CSV that aren’t being displayed properly in Notepad. You may find additional weird characters using a different editor like Notepad++

I changed the order line number to 0 on each line and it’s trying to create a new order for line two as I’m getting a duplicate PO number error. I have several BPMs running against sales orders. We used to do this in 9.05 without issue so I’m stumped as to why I can’t do this in 10.2

My DMT version is 4.0.36

I receive the same error when trying to import as an xlsx file.

I also looked at it using Notepad++ and it appears the same as Notepad


What is the result if you don’t use the SOCombined template?

I do not have 4.0.36

I can import with PO with # and the Part with “.” so I do not know how to help you further apart from sending you my DMT Template that worked for me.

I use EXCEL to modify the CSV file.

Krista.csv (324 Bytes)

Also make sure the Preferences in DMT is ,


We are using 4.0.34 for 10.1.600

Here is our template for SO combined. The process I use is create the sql query in SSMS run it and copy paste with headers.SPCombinedTemplate.xlsx (9.0 KB)

One of the issues I had was if we had one line with an incorrect UOM the subsequent order lines would fail.

I believe the problem is OrderNum=0 which is setting the next order number, but I assume you have that customer set to CheckDupPO=true which prevents the second duplicate sales order from being created. Why not just create the next OrderNum in your series and assign it instead of letting DMT handle it?

1 Like


I checked my DMT preferences and they mimic yours. I also tried using the file you provided, but still received the same error on line 2. Thanks for your assistance!

Since DMT processes one line at a time, passing a 0 for the order number and a line 2 does not make sense. If you cannot predict the sales order number in advance, you will need to make two DMT files, one to create the sales orders and the other to add the lines. I’ve had to do this for labor details DMT loads and although it stinks, you can do this with powershell scripts.


1 Like

I have the same issue with your file as well. I appreciate your help!!

Have you tried disabling all of your BPMs?

That’s going to be my next step.

Just seems odd that it can’t be done. I did this over and over again in 9.05.

If you only want to do one order at a time (judging from the conversation of wanted order number 0 to make a new order and all be the same), couldn’t you just make an order and then in the list tab do a paste insert for the lines?

1 Like