E10: Maximum users exceeded on license type (EDD Issue)

In case any of you are experiencing this issue (when the max user count hasn’t actually been exceeded) - it appears to be triggered by EDD, and there is no fix available yet. We are using E10 Public Cloud.

As per Tech Support:

Thank you for providing the most recent data–it was what allowed us to determine that this behavior is a known issue to our development team. The software change request is open with our development team, but, there is not an ETA on when a software change may be available as they are in the research phase of the R&D process. It will most likely not be changed by the time ERP 10.2.600 is released next month. The workaround until this change is implemented into the application is to log into the client either into the classic menu or modern (not active homepage), and use only the classic ERP forms instead of any of the new Kinetic versions. Linked is a knowledge article on how you can disable kinetic forms for a user account for your review. Please let me know if you have any questions Knowledge Article KB0090087 - Opt out of Kinetic forms for an individual user account (10.2.500)

Hi Glen,

Are we certain this is only a Public Cloud issue? Sounds like it may apply to On-Prem too as the licensing system is the same.

Mark W.

1 Like

Good point, Mark - no, I am not sure. I will change the title on the post, and see if anyone else provides feedback on the issue. Thanks!

I know there are people on this list who are on the Kinetic preview program. They should make sure that the official recommendation of Epicor Support is to turn off Kinetic functionality. I know the Kinetic Team are promoting it heavily so one would think this would get more attention.

Yeah, we have just been picking up on all the new Kinetic forms from recent updates, and 10.2.600 just deployed to Pilot over the weekend. Kind of a crappy workaround - Kinetic is so much nicer.

1 Like

Thanks for raising this issue as per the ticket. I have escalated and we will provide guidance soon. If necessary we will provide a temporary license. If you have pilot already upgraded to 10.2.600 that would be useful to verify if you still have the issue in that version. Thanks

1 Like

Thanks, Stephen! Appreciate the escalation. I will have my Technical Analyst (Eli) see if we can reproduce in Pilot (we are on 10.2.600).

@Edge The only way I’ve found to reproduce it for us was to have 2 users sign into EDD on the web at the same time. Unfortunately since we don’t have premium pilot, we aren’t able to use EDD in pilot. We can try having multiple people access kinetic pages at the same time though.


We run into this with on-prem 10.2.400 when people are using EDD. It’s a rather annoying bug…

1 Like

Hey folks I want to jump in with more information:

FYI we did fix a bug around this with EDD at 10.2.500.8. where while it was running a query it can consume a license momentarily so it can briefly over-consume. We had a similar bug with docstar solved early in the year also.

After discussion with support on this to me it looks like the inbound fixes from edd/docstar obscured the fact that there may be another similar bug in other kinetic applications. We’re looking at this now with support and if there are more issues they’ll get a priority fix. At this moment I think it’s likely we do have an additional problem based on what I’ve seen so far and discussions above.

We’ll keep you all updated and as Stephen said if you need a temp license in the mean time will provide it.

ps. In the future if you are trying to get help via official channels and getting a baffling response or a runaround with respect to Kinetic anything please feel free to reach out to me directly and I can help cut past the noise. I’m also interested in direct feedback as always.


@Edge - this is the issue I was struggling with when I last saw you in person at the EUG event. It’s resolved on our on-prem install at this time. It relates to the fact that EDD does an auto refresh on a schedule, which keeps the license active even if the user is away from their desk.

After making this change, the issue went away for us. Users know to press the refresh icon to get latest data - and if they’re at their screen pressing that button, they are probably using Epicor anyways:

Steps to change the auto refresh interval (obviously goes without saying that you will backup that file first before changing it…!):

• Note: after making this change the views will not refresh automatically, user will need to refresh manually to update the view. Customer can change the settings back to 30 once they are done testing.
• Open sysconfig.json in the data discovery deployment directory on the server
• Locate the cardview and iotWidget sections and tune to change the automatic update timer for edd views when embedded

Setting autoRefreshIntervalMin to zero will disable it entirely.

“cardView”: {
“autoRefreshIntervalInMin”: 30,
“enableAnimation”: false
“iotWidget”: {
“autoRefreshIntervalInSec”: 30



That is also true holding back autorefresh would mitigate the issue with edd somewhat. If nothing else you would have less collisions. Not really a full solution but it gets you there mostly.

1 Like

It’s what solved it for us for sure - we have more people who use Epicor than concurrent licenses, but the law of averages works and it was infrequently that we saw the Max Users exceeded - until we installed 10.2.300 with EDD! The very first day after upgrade we were seeing that message all the time. We had a temp license, and it showed us peaking up at 48 users where our normal is 25. Even if I wanted to purchase a couple more licenses, the cost of doubling it was not in the budget shall we say…!

With the auto refresh turned off, we still use EDD on Active Home Page and love it. I’ve created some nice dashboards. There are a couple of queries that I have over functionality now that I’ve used it more, I’ll start a new post!


Thanks for jumping in, Brian, and for the transparency. This has been a frustrating issue for us, and the support response was also frustrating (we are aware of the issue, won’t likely be fixed in 10.2.600, please hold…:grin:).

What is the best way for us to go about getting the license to prevent the errors until a fix is released? We do have an open support ticket, but they are asking to close it.

If you’re on-prem, definitely review the auto refresh setting that I refer to above. Solved it for us - the only impact is that you have to manually refresh the EDD tiles.

Nope - we are Public Cloud (see OP).

Support should assist witht this, but if you give me the ticket # I’ll reach out to them direct about it.

1 Like

Hey Brian!
Thanks for your assistance! Our ticket # is CS0002002405


All I’m back to confirm that we did find a real bug where kinetic home and our new kinetic screens can without any edd installed cause a similar problem and we have a fix in the works right now for 10.2.600.4, which i suspect we will be retrofitting as requests come in as well.

If you’re seeing the issue with only EDD in the mix that’s almost certainly the EDD bug which was solved in 10.2.500.8, but there is another way to run into a similar issue regardless. It’s harder to reproduce it as it’s timing based but it’s real and in progress with a fix.

1 Like

Thanks again for all your help and expertise with this, Brian! @bconner