ECM Upgrade Down Time v22.2.109 to 23.1.58

Hey there,

We need to upgrade our system and have no clue how long it’ll take. Anyone have an idea on down time? There isn’t too much traffic between DocStar (ECM) and Kinetic currently, outside of engineering/PC for sketch sheet storage. Additionally, regarding attachments in Kinetic… we’re only able to download them from Kinetic. They’re not viewable, nor are we able to open in DocStar. Clearly we need some config adjustments, hence the upgrade. Hopefully the above context could help troubleshoot how long our upgrade may take… 1ish hour or 7, we have no clue. Any input would be great, thank you! IT dude is only available for so long lol. :slight_smile:


In my OnPrem environment that would be an hourish. Where is the ECM installed?

Thanks for the info. We’re OnPrem as well.

Maybe less. I just went from 107 to 58 in 20 minutes.


On-prem as well. I just did the 22.x to 23.1 upgrade on my sandbox and it was about 20 min. Figure on another 20 minutes to manage the VM snapshots and some basic testing before I tell the users…

After you’ve done the upgrade, open an EpicCare ticket and get back to us with some details. I’m not sure how you got into this position, but I don’t think we’ve heard of anyone with a problem like that.

On the surface it seems like someone messed up the Security Class or security options on your content type… but that’s just a guess.

1 Like

@gpayne - Did you get any errors relating to Solar Indexer?
Every window with a ‘search’ grid on it gives me an error…

it was my dev box, so I just verified the version and went back to my other project, but I just tested and am getting this error.

ok - found a KB on EpicCare, tried some other things - no luck. Opened Case CS0003724116.
We’ll see what happens and create a separate post when I get an answer.

I opened a case also. I was looking at the Solr panel and I think it has to do with updating and rebuilding the index. I changed it to 9.0.0 and the error changed in the log, but it still was not working.

1 Like

My bad, just realized you asked where we have ECM installed. It’s on our server.

Is it a pretty straightforward process or should I try and track down some documentation?

It is very straight forward but it also broke mine and @MikeGross’s ECM, so I would hold until we know how to not break it.

I’m wondering if our “Transfer Type” settings in Attach Type MTC were configured incorrectly at square one.

The upgrade install is easy and mostly foolproof until you find something like we just found.

Honestly - for all you want to accomplish (and fix) you might need to go ahead and get some Professional Services time with an ECM consultant. While we can help with all of that, it’s a lot to get set up, connected, and tested.

I just rolled back to 22.2.104 and am testing that if I go to the last 22.2. which is 128 before 23.1 does it make the needed config change.

Agreed. We have a plan in place with our rep. I was hoping we could complete the upgrade at least prior to our next mtg. He said it shouldn’t be a problem. I just have basic questions… Should I assume that our attachments in Kinetic will be unavailable while an upgrade is in work? I don’t know all the dynamics in that regard. Anyhow, I appreciate the input/comments. Thank you :slight_smile:

The upgrade is in reality a complete uninstall/reinstall of the ECM server components. Yes, ECM will be unavailable until the process is complete. But then it’s completely available, immediately.

SO if you want time to test things before the users get in, then you need to figure out how to communicate with them that you need time before they start working again.

1 Like

Just got off with support. The issue has to do with the hotfix for 21.2.68 causes the uplift from Solr 8.11 to Solr 9 to fail.

Steps to avoid the issue.
Check that Java is at 11 or higher.
In Control Panel - Programs and Features uninstall Solr

Open the Server configuration and get to the index page to locate your index folder

Rename it to something like SolrSC old
Open C:\Progam Files\Astria Solutions Group and rename Eclipse Solr folder
Run the install and when it launches it will rebuild the two folders and the indexes.


First - how’d you get support so quickly? Did you call them and wait for them? :wink:
Second - Java - do you mean V7 Update 11?
Third - the Solr uninstall calls for a reboot - do it now or after the reconfig steps?
Last - can you put up your ticket/Case # ? I’ve got a session as 11:30 EST with support.

I rebooted after Solr uninstall, got into the Sever Config and renamed Index location, and leaving Server Config open, got into File Explorer and renamed Solr folder, then finished the Server Config. Got a new Program Files Solr folder, but not a new Program Data Solr folder. And the error is still there.

So I went back in to the Server Config and changed the folder back and clicked the Index checkbox

Now it works.

1 Like

I entered a web case, even set it as my dev box and not urgent and I got my call just after he had finished with yours. Hmmm, He said I just finished with another customer that had the same issue and I asked if it was Mike Gross and he said I think so.

Case CS0003724328

Here is the note from Solr regarding the java version. I went to Oracle and downloaded and installed 17, which got upgraded to 18.
Java Downloads | Oracle
You can see the versions in the Solr Panel

On the System ReIndex for me, the Solr version was 0.0 so it was auto checked. We also went into ECM as admin and deleted and reindexed in there.

1 Like