Epicor 10.1.600.29 get error adding company in admin console

I’m setting up a test server for 10.1.600.xx . I have added the license but when I try to add the company I get the following error ''Incorrect syntax near the keyword ‘FROM’. I have a call into support but thought I would run it by you guys also.

  1. What is the exact name of your database as shown in SSMS?
  2. Which SQL version are you using?

The database name is ‘Test’ in SSMS and the sql version is “SqlServer 2014 version 12.0.2000.8 (X64)”.

What version are you coming from? I wonder if there is a required extension for the admin console.

Might be worth performing a SQL profiler and trying to add, capture the results and see exactly what the TSQL query is being generated when you add a company. Still not going to help you fix the admin console, but it will surely help Support.

I had a sort of similar issue on my test environment. I had 10.1.600 and upgraded to When I tried to register the appservers I got a assembly missing error. I ended up uninstall the new admin console and reinstalling just to the point release, then it was all happy, as soon as I ran the update I got the error again.

and sorry @aidacra I have not logged this with support, from my readings It doesn’t seem correct to have 10.1.600 and 10.2.100 appservers running on the same machine. So I didn’t think it merited using up precious resources on this.

Apologies for the hijack.

We are currently on 10.1.500.27 but this is a new install and I have not brought in a database yet. Not sure if it matters but was running on this system with no issues. I uninstalled it and deleted all the directories before starting the install for 10.1.600. I wonder if there are still some settings pointing to 10.2 and causing some issues? I have tried to uninstall 10.1.600 and all components and reinstall and am getting the same error.

This is the sql its having trouble with.

If this system is setup for 10.2, it will require an extension for the AdminConsole to work with 10.x



1 Like

Chris thanks for info. I uninstalled all Epicor components and deleted the database. I then did a complete new install and I’m now able to add the company. Not sure what the problem was but its working now. Thanks for all the help everyone.