Epicor 10 and Terminal Servers

Is anyone using the RD Web Access server from Microsoft for Epicor 10?

We are testing it and I am getting an error… when I try to launch Epicor via the web access.

We run pretty much all clients as RD Apps. The few that don’t do so for local printing issues.

I’d bet what you are seeing is a permissions issue with between the User and the RD server. And shouldn’t be client O/S dependent (the O/S of the workstation connecting to the RD App server). The “C:” it is referring to is the C: drive of the RD App server.


I’d agree with @ckrusen on the permissions.

I can see a good explainer coming on here…I’m assuming you use /SKIP in your parameters and when you do an update you login to each server and run a shortcut with the update version? That’s how I have done it, is it the right way…not sure really.

1 Like

Yes, i figured it was on the RD App Server but can’t figure out how to get around it. I was guessing today it was a permissions thing. Do you have to have certain permissions to that folder to run this. I know nothing about this and working with my server team to figure out how to get it running and they know nothing about Epicor. LOL

Is it a setting on the RD that is allowing the app to be published or it is it on the local TS?

Any guidance would be helpful.
thanks a million

Publish the App, but make sure the that the users or groups that are configured in the user assignment of the Published apps properties have full access to the client folder on the RDS App server that is hosting the Epicor client.

The message at the bottom of the User Assignment section says.

1 Like

Agree with @Hally. Also, EpicCare has a KB article about setting up Remote Access.

1 Like

Ok I gave the group full control to the local Epicor folder on the RDSApp Server…still same error. Is it on the RDS App Server or where it is being publlished from. I don’t know this well so not sure I am explaining it well. Everything is controlled on another server…

I would think this would be fairly simple so I don’t know what I am missing.

I don’t know all the details of our RD app server setup. I just manage the Servers that host Epicor App System (the one where E10 is installed and EAC is run), and the SQL server.

While we have an RD server that manages the RD Apps, they actually run form the E10 server.

If I go on the E10 server, and launch Process Explorer (a much better version of Task manager) I see the other users, that connected via the RD App server.


And for what its worth. We don’t have a file named default.sysconfig in the client folder on the E10 server. At least not in C:\Epicor\ERP10.2Client\PRD_102300\Client\config. Here’s our Client folder’s confg files:

  1. PRD_102300 is the sysconfig file for our Production App
  2. PRD_102300_WUC is a sysconfig file for an alternate connection to our Production DB.(this App uses UserChannel binding)
  3. TST_… and UAT… are to test environments
  4. Looks like a Default sysconfig file. but has ‘.template’ tacked on to it.

Is the issue with a particular user, any user from a particular workstation, or something else.

One last thing. Make sure the users remote station is logging into the domain, and not their local computer.

Right now I am just testing it. I created an AD group and that group has access to the published App (Epicor). I have 2 log ins and put both in that group and one of them is an Admin on the server and still get the same error. I have the similar files in my config folder…not dafault.sysconfig just has the template.

What do you mean by Make sure the users remote station is logging into the domain, and not their local computer. ?? you mean as a domain user on the Web App?

not sure if any of these screen shots help or not…I mean if others are using it I must be missing something…Just don’t know what…I have suspicions.
I can get here…

then is starts…

but then fails here…

This was before I had more info on your issue.

Most of our users have laptops and occasionally someone will login to the laptop instead of the domain. For example, my computer’s name is CKRUSEN-WIN7 (even though it running Win10), and our domain name is ATIUS.LOCAL. When I first login on the workstation, I can either have the workstation (CKRUSEN-WIN7\ckrusen) authenticate me or I can login to the domain (ATIUS\ckrusen). If I login to the workstation, I’ll probably not have rights needed to access resources on our network.

oh ok, I understand. No all users are on domain.

Is the client program installed on the RD server? Becaus that error message looks like its being generated by the RD server. So any reference to “C:” would be the C: drive of the RD App server.

Should the RD server be setup to point its shortcut to the E10 App server? Something like


where Epicor is a share on the server named E10_server, and maps to “C:\Epicor” on E10_server.

FWIW - The RD App gets downloaded to my workstation (because I use Chrome and not Edge). So I can see all the settings it uses. I noticed the setting highlighted below uses the /Config switch. Are you using that in the RD App setup?


And yes… We still use the Classic shell.

Just a stab in the dark here, but what are the security settings of your c:\ProgramData\Epicor Folder.

Ours are
image .

I’ve been meaning to look into the Epicor Temp folder in more detail. I know when installing the old Epicor Clientel/eFrontOffice on Terminal services you needed to setup the users profile to use it’s own “mapped” folder for temp files. That being said we are running the default config and things appear to be functioning.

1 Like

I think the fact that most files get the user name added to them as a suffix, has taken care of the problem for users to need separate folders.

@Hally @ckrusen We figured it out. We were missing a parameter setting on the Broker server.

1 Like

If you are hosted on Azure, WVD is the next big thing and looks pretty dang cool. You can apparently deliver just the app like RemoteApp or the full desktop experience.

1 Like