Epicor DUU

Hello everyone! I been banging my head for the last month and still stuck at the same spot. Hopefully some light can be shed!

i am doing an upgrade from Vantage 8.03.409C to Epicor 10 through the DUU utility guide.

I backed up my prod db to my test (SQL) then i created a new server (OS:2008R2). I installed SQL 2008R2. I installed progress 10.2a as a 32 bit application. I then installed epicor 9.05 wiith the DUU.

Everything as the guide states. Then i open the DUU utility and select my backup db file and my uom file, i select the current server to install the upgrade DB. When the screen ask me to select an sql instance, i select the current server instance and it just says that the Instance is not compatible. Support told me to restore the backup db manually.

I restored the DB manually, then i ran the DUU again and skipped the restore of the DB. I followed the guide and ran the schema change. The schema change ran and came back with 0 errors. i start the app server through progress tool (i was able to open progress explorer through changing the Java binary from 1 to 0 since this is a 64 bit server). Then i go to open the 904 admin tools and i get the error

Schema holder does not match database schema – file dbo.cntgver field v_803500

i re run the schema change but it states that no schema change required with this message:

Database level:8.03.400 program Level: 9.04.508 No Schema Changes required

Support is looking into this but i am in the same spot for a month. Can anyone who went throught the upgrade process seen this error? or any hacks that are not included in the DUU guide. I have looked in the forum but cant find anything.

Any guidance will really be appreciate it! Thank you so much!

:PS i have started over more than 4 times, trying to have my SQL on a different server than my application and i just get stuck on the same step.

1 Like

Have you considered the epicor upgrade services they are much faster and more efficient than the DUU?


Thanks Jose! I contacted them to see what they would quote me, but i thought i could upgrade the DB following the guide. They purposely left the special sauce on the guide because i run into issues on every step not mentioned in the guide!

did everyone just used those services upgrading their DBs? I know that from vantage to E9 is the real headche from different post i have read.

No, I’ve done it using the DUU works fine. But their cloud service is amazing I was involved in the early stages of beta testing and I can attest it is a fantastic product written by the amazing guys from the .NET IT team. Well worth the money and not very expensive at all.
The amount of time saved alone will be worth it.

But DUU does work …it’s just painful

I recommend you to to 410 first from there use the DUU to 9.05.702

Thank Jose! Will look forward to hearing from the their team!

In the meantime, i will try your suggestion. Thank you!

I dont know the DUU, but I used Epicor Migration Services as well, after I was trying to upgrade from Progress 702A to E10.

I paid their $2k for 3 passes. I did a cloud transfer to their server, and they started to convert. There were some errors that occurred and they fixed them on their side. 36 hours later I had a E10 version of my progress DB on my sql server. Their conversion tool has come a long way.

1 Like

i have contracted Epicor Services. Thank you all!

Miguel, how big was your Db? When reviewing the upgrade process, was there any step where it didnt seem to update/ move for hours? (the duration was on the same # as well as %?)

Thank you


Database currently is about at the time was 60GB. 46GB of data and 14GB of index it states.

During my Cloud Worker and Cloud Conversion. But that was probably because I had an issue, then they fixed it and I didnt get a chance to see the progress anymore because when I knew there was an error. Email was sent to me. I didnt expect them to fix it so quickly, but they started the process again and before I new it, my DB was done.

Thanks! Miguel! Thats good to know!

the run conversion has been on 88% and 42 mins for 2 days now. Epicor says its still running maybe it takes longer from 8.03.409C instead of 9.05.702A. Will give it a day or two before i ask them again!


Thinking the same thing, you have a few extra layers with 8.XX. It will error out when it fails and you should get an email indicating so. Good Luck.


Great! Havent gotten any errors or email yet. So thats good news!


Hi Jose.

Did Epicor ever come back to you with a response to the…

Schema holder does not match database schema – file dbo.vntgver field v_803500

… error in the DUU? (I ask as I have the same, and will get it working).

Yes I know that the Cirrus / Cloud upgrade is an option but I’m a stubborn bugger and want total control over the upgrade process and date I do it, plus I’m angry that Epicor have used the skills of what was Dot Net IT etc. to create this cloud upgrade product that we have to pay for ON TOP of our annual maintenance.


Hi, Unfortunately support never figured that out so i ended up going with the upgrade services. Currently going through the second pass. In doing so though, i see they go through the DUU steps from whatever version of vantage you have to 410 then from 410 to 9.04 then to 9.05 then to 10.1. On this specific issue never got an answer from support. they tried all the steps i tried and kept getting the same error. I even sent them my DB and they still had the same issue.

PS: The first time it ran through the upgrade services it took a long time for them to convert it (~month!). The second pass just finished in 3 days.

Which version are you on right now?

I’m on 8.03.408 (I’ve performed upgrades to E9.05 at other businesses I’ve worked at).

I’m competent with VMware ESXi so I’ve a stack of VM’s…

  • v 8.03.410
  • v 9.05.702a with the DUU
  • v

… using a flash SAN so I’ve got the fast hardware, I’m just having to struggle on with the tools from Epicor (nothing from them ever follows the documentation 100% does it).

Edit 1: I’ve a support call open with Epicor on this, going through the usual ‘whack a mole’ with them until they find the actual root cause, however the upgrade AppServer will not start as some tables are missing from the 8.03.410 DB after the 9.04 schema change (I did tell Epicor about this). I scripted them out to a ‘create’ from SSMS, the tables were ReplicationLog + ReplLogChunk + ReplSetting.

Edit 2: With the replication tables added I now get a schema error in the Upgrade AppServer log file…

Schema holder does not match database schema – file dbo.sysagenttaskparam field bitflag. (1461)

… so I’m truly hitting Jose’s original problem. I’ll be on Epicor like a dog with a bone :wink:

If you find a solution, please let us know. i never was able to figure this one out. I ran into the same troubles you did as i have the same configuration when i was doing this!

Well, when things like this occur I’m a dog with a bone and will be a thorn in Epicor’s side until they honour their commitments (which the business I reprent gains by paying them tens of thousands of pounds each year).

Here’s an update for you…

  • The Epicor support call is still open, and it took a week and half until the support employee said the version of the DUU I had was not the most current, and that I must fill out a form for it to be released to me.
  • I then contacted our temporary “Internal Customer Account Manager”, as our CAM has left Epicor for another ERP vendors business, to obtain the form required.
  • They got back to me four working days later, spent half of the call selling Project Cirrus, and then said they’d need to go through their legal team to release the latest DUU to me.
  • Here’s the real kick in the teeth though, to obtain the latest DUU I have to accept that Epicor will offer no support on it at all and that it’s provided “as is”.
  • I accepted this as I need it, however this really annoyed me as the DUU documentation for the version that accompanies 9.05.702 is from mid 2014 so at this point in time Project Cirrus was just a gleam in Dot Net IT’s eye and the DUU was a supported official Epicor tool. So am I to assume that the refusal of DUU support is a tactic from Epicor to steer customers to Project Cirrus and gain revenue?
  • So here I am, two working days after our temp CAM said they’d sort out the latest DUU for me and I’ve heard nothing back from them.
  • Something else that annoys me is that the temp CAM does not reply to my e-mails, they only call me a few days later. I’m always wary of others who do not directly reply to e-mails, and thereby avoid physical evidence of a conversation having occurred. More annoying is that I sent an e-mail to their superior, and they also chose to not reply to me!

… so right now I’m stuck in Epicor support limbo, some thing never change do they.

I was in limbo for more than a month! and only got a response saying they didn’t know what the issue was lol

I have no technical solution to offer but just an observation really. Epicor would like to sell you Upgrade Services obviously, but in the scheme of Epicor charges from the estimates I’ve heard it really isn’t expensive for what you’re getting. You’re buying the speed of cloud to do the upgrade, and whilst I am in the same boat as you of being on-prem and having decent SAN etc I think it would still be quicker on Azure. You’re also buying the combined knowledge of @Edge and his team, plus the experience gained from doing many thousands of upgrades at this point.

As for the response from support, you’re asking for support on a product which is 2 major versions behind and many years old. I think as customers if we all buy into the Epicor philosophy of staying current then actually the same number of support staff would be working on the same up to date platform and the service level would increase.

I’d say bite the bullet, do Upgrade Services this time and then you are in a good position to be able to stay current on-premise using the normal upgrade path. Any issues you do encounter will be much more easily fixed as it’s current code that’s being continuously developed.