Error "User Account is not set to ‘Allow Session Impersonation’" when said checkbox is set

I’m getting the following error when I try to run MRP:

Program Ice.Services.Lib.RunTask raised an unexpected exception with the following message: RunSubTask: User Account is not set to ‘Allow Session Impersonation’

Problem is, when I go to User Account Maintenance, under the Options tab and the “Background Task Permission” sub-pane, “Allow Session Impersonation” is checked.

MRP is running as my user id - I can see that in the system monitor. So why is it saying I don’t have this permission?

Your account used for the TaskAgent must be enabled for impersonation I believe.


System monitor is showing who executed the request. Not how the process is running. The process should be running with the task agent. The task agent configuration will have a user account. That account need impersonation. The System Agent maintenance screen will also need to be set to the same user and password if it is not a windows binding.


The KB article that goes through the requirements of the user account set on the system agent and taskagent, and how to set session impersonation (and lots of other general troubleshooting steps when printing in general doesn’t work) can be reviewed in the KB linked below. It was my first “one doc to rule them all” article for an issue–ahh, memories:

KB0039354 PRINT all background processing tasks are sitting in scheduled tasks in System Monitor

1 Like

I got a 404 error.

But at least the 404 page has a nice little Breakout game embedded.

1 Like

I printed it to PDF and attached it here for review as I know you are paying your maintenance dollars :smiley:
KB0039354 PRINT all background processing tasks are sitting in.pdf (61.7 KB)

1 Like

Nathan, thanks!

I almost started to suggest non SSO in this post but wasn’t sure that was the preferred. That is how we are setup. One app server for users and one for the task agent and system agent together. I just had a big gotcha when testing the 10.2.300 upgrade
that was completed this week at one of our sites. Thanks for your support!!

**Josh Owings **| JR Automation

ERP Applications Manager

O: +1
(864) 397-9193 | C: +1 (864) 884-6587

Sure enough, that fixed it. The Task Agent and the User Agent were different users, and furthermore it doesn’t appear that “manager” can impersonate (when I tried to set that flag and save I got the error “You are not allowed to modify global security manager privileges”. Once I changed both users to a totally different account that had permission, MRP ran to completion in only a few minutes.


Happy I could help @Epicorus and glad MRP is now MRP-ing for you :slight_smile:

1 Like