Foreign Key is Read Only

I am creating a Site Configuration Control. I want the Custom Field in the Plant to be updated, but the main table in the form is the PlantConfCtrl. When I try to add the Plant table using a Foreign Key View, I am not able to modify the field. How can I set it up to change the value in the Plant table from the PlantConfCtrl field?

Hi @bobbyu11
What you are trying to say is that the custom field on the form is read only and you cannot edit it, correct?

Epicor gurus can answer why it is like this but the way that it worked for me and I learned it in one of these forums (so no innovation at all!) is to create a Foreignkey View and then build a Sub Table View on top of it like this:

This should work for you. Let us know how it goes :wink:

I tried your method and am still having it as a read only field.
Could we do a zoom call?

Hi @bobbyu11 ,

I just checked your hosting and it says it is a cloud hosting type.
Is it still a desktop version that server is hosted on cloud or is it fully cloud with no desktop client application?

No, it is desktop clients

FKV is always read only. If you want to bring in a different table with read / write you’ll have to bring in table as a child or use an embeded dashboard / UBAQ.

Thank you for clarification @josecgomez
That makes sense.
So what I suggested should work, right?

Hi @bobbyu11 ,

I would stay away from zoom calls and inviting strangers into our system if I were in your shoes :stuck_out_tongue:

These are the steps that I followed:
1- Added FKV
2- Added STV on top of FKV
3- Clicked on the custom field that I was interested in using, and in bindings, found the STV and inside STV found the field that we wanted to modify.

That is it.
It should work!
Don’t forget to clear client cache and restart your client to see the changes in case there is any residual cached data

I am following what you said and just can’t get it to avoid Read Only.

I believe you @bobbyu11 :slight_smile:

Can yuo provide answer to these questions?
1- What menu are you trying to customize?
2-What is the field that you are trying to change (the same field that you have created a custom textbox or radio button or … for)
3- Where does this custom field reside (what table did you create it in)?

I want to replicate the situation first and get back to you. :slight_smile:

Well you should turn the read only to FALSE my friend if you can. Maybe that resolves the problem.

The FKV is for Plant that I am trying to connect with. This is on the Site Configuration form that I am trying to connect the field from Plant table.

I have tried to change the ReadOnly to False and it will not go. I have also tried to recreate after the above steps, but it still goes to ReadOnly = TRUE.

Hi @bobbyu11
Sorry It seems I misled you inadvertently.
The second FKV is not required.

I will create something on my end and post it here with details. :wink: