Having some performance issues

Hey guys and gals,
Wondering if anyone else has had this issue. I am all of a sudden having performance issues with certain processes. For example, I am just trying to delete 1 invoice from an AR Group, but it times out. I am getting this message in the Server log

[21/02/15@10:15:59.784-0500] P-001660 T-006336 1 AS – (Procedure: ‘InvcHeadDeleteRow bo/ARInvoice/ARInvoice.p’ Line:9858) Lock wait timeout of 180 seconds expired (8812)
[21/02/15@10:22:52.479-0500] P-005536 T-008260 1 AS – (Procedure: ‘InvcHeadDeleteRow bo/ARInvoice/ARInvoice.p’ Line:9858) Lock wait timeout of 180 seconds expired (8812)

Have you first tried deleting all the lines from the invoice?

I’m guessing that deleting an invoice header, has to first delete all the lines. And if deleting the lines is taking too long, than the call to delete the header times out. Just a wild guess.


It is a good thought, but the group only has 1 invoice with only 1 line. I have a unique setup and that causes me to have to delete invoices from groups daily. It is a process I do daily and never had issues with it timing out, until this past Friday. Nothing was changed or modified. My accounting team was complaining that the posting process was not working and I noticed I couldn’t even delete an invoice from a group.

And the weird thing, is that it won’t work for a while, then all of a sudden it works normal and posting works and deleting invoices work fine.

It sounds like some other process is locking the record.

I assume that there is a reason that the invoice is created, only to be later deleted. Like for printing Proforma Invoices. Is there any other process that runs in the background that uses Invoice records? Like a BAQ on a schedule (not that a BAQ should be locking records).

Just out of curiosity, can you edit that invoice in Invoice Entry? Just to see if InvcHead is locked from changes too. Just try something simple like changing the Invoice Comment.

And even though there is just the one line, can you delete it? Also, just seeing which records might be “locked”

No, nothing should be locking it. It is weird, cause one second I am getting timeout errors and can’t delete an invoice, but if I wait a little while it allows me to delete it easily. It is very inconsistent and Epicor support is not helping at all. They are clueless, unless you find the unique person who actually knows a little about Epicor. I am at a stand still right now, cause we can’t trust Epicor to actually do anything.

@ahsalloum assuming this is SQL do you have the locks logger 3 script from Epicor support? If you watch SQL activity monitor and the appserver memory does a higher load correlate with the issue? We had an issue with some badly written baqs and reports that would cause this. The logger helped me find those and get them fixed or banned.

The further you get from current the fewer support people will have a background in 9. Having been on 10 for almost a year now it is amazing how much less babysitting it takes.

Good Luck.

Thanks for you response. I am SQL and I will monitor the activity monitor and see. My appserver memory is running low now and shouldn’t be related. The example of deleting an Invoice is one of the smallest processes I can try and it sometimes works and sometimes doesn’t. So far, I don’t see any reason from the logs. I have rebooted my appserver and dbserver multiple times since late last week and still not help. I would assume if something was locking the processes, it would clear from a reboot, don’t you think.

I don’t have the lock logger 3 script. is that something you can give me to try?

Are you 100% positive there is nothing that could be locking it? Have you checked BPMs, BAQs, customizations, External tools?
Have you used the Performance Diagnostic Tool to ensure you have all the right SQL settings?

1 Like

I found a scheduled BAQ that was running in SQL over and over again. I disabled the scheduled task and rebooted. The issue seems to be fixed, so far. I tried to explain to the Epicor support agent that nothing was showing in the logs, but he spent the entire day on the logs. I was getting responses from him every 3 or 4 hours. If he would have just did a Webex with me and poked around, we could have probably found it earlier. I don’t know much about SQL and just happen to find it poking around myself. If he would have listened from the beginning, he would have checked the SQL server first. I need to get to Epicor 10 fast. The support for 9 is really struggling. I am in the process of upgrading to 10 now. Hoping to be up and running on 10 by summer.

1 Like

Good news. Best of luck!

@ahsalloum It is Epicor’s so I won’t post it here, but if you have E10 PDT then under help there is download diagnostic resources and it is there as deadlock analysis sp_lock3. I used it in 9 and have it loaded in case I would need it in 10.

1 Like