Job Details Customization - MES - Doesn't show in Menu Maintenance


I created a customization for the Job Details form (MES → More Info) and I am unable to get it to be a selection in Menu Maintenance → Processes → Job Details.

I checked “All Companies” and I even re-imported and recycled the app pool. I have screenshots below, am I missing something? Thank you for your time!

Upon clicking the More Info button on the MES main screen, I get two prompts for the process call:

The second one shows the ID and that’s how I validated it in the menu maintenance, but it doesn’t list it:

But as you can see, I have a customization:

Not sure if this is your issue, but in previous versions you had to make the customization available to ALL companies for it to show up in this drop down:

This bug may have been fixed already.

Thanks, might not have been clear above but I did check the All Companies checkbox.

1 Like

Will you export it and then re-import it using the all companies checkbox?

I did that too, I mentioned above I checked All Companies, then I re-imported and I even recycled the application pool. Still nothing.

Since this form was built with the intention to be a system call from another form, could this be why the customization doesn’t show? Do I need to change the behavior of the More Info button, or replace it with a custom button, to load the form via custom code and include the customization that way (I remember reading a post on here on how to do that)?


You can call support, they will help you.

Does the system call from another form have a customization. Where is it being called from?

The Job Details form is called from the MES main screen’s More Info button:


The MES Menu does have a customization.


Try creating a customization on form PR000037 and rename both customization names to be the same.

1 Like

You are the best! I remember having to do that before just can’t remember where. I will try and get that done today and see if that resolves this issue and will mark your response as the solution. Thank you!!


I was going to suggest that @cchang ! But I couldn’t remember if that applied to the drop down or not.

Sadly that didn’t work.

First, I imported and ensured I checked All Companies and named it the same as the MES Customization:

MES Customization:

Import of the Job Details customization:

Just to show, nothing shows up in Menu Maintenance:

I appreciate the help on this! Let me know if you have other ideas/thoughts. Or would we need to manually program the form load to force it to load the customization?

Thank you!!

Your first screenshot doesn’t look correct. The customization should be on form PR000037 first and not in MESMenu. Whatever customization you have on form PR000037 that is selected in your third screenshot should be used in your second screenshot.

Sorry if that was confusing, the first screenshot shows our customization and name for the MES main menu. The second screenshot shows the customization for the Job Details form (PR000037). I wanted to show that I imported the customization and the name matches the MES main menu customization per your recommendation above.

The third screenshot was just to show that the customization that was imported for Job Details doesn’t show in the drop down, just like my original issue.

I hope that is more clear, let me know if not, however. Thanks!

Are you in the cloud? Don’t you have to create a new menu item for the PR000037 first to be able to apply your customization? The Module would be UD but with the same Menu ID.

Hello! No we are a local installation. We tried creating a custom menu item, UD, instead of using the default one but still the customization doesn’t show:

If you’re on-prem you don’t have to do that. But the customization on both the form and the process being named exactly the same is correct, I remember that much.

Your Program icon should be Process.

EDIT: Sorry, I was thinking type, smh buuut what about your enabled checkbox? Is it checked?

No worries! Yeah it was, I unchecked it because we disabled the regular Job Details menu item, but then when the custom menu didn’t work I tried to bring back the Job Details menu item and disabled the custom menu to try and have Job Details show up in the list again (I can manually set Job Details to enabled in Ice.Menu but it still doesn’t show).

I appreciate the help btw, this is stumping a couple of us here. Never had this kind of issue before.